Problems with PhotoWiz Plugins under Win 7 with PhotoPlus

General discussions ColorWasher, FocalBlade, LightMachine, B/W Styler and ContrastMaster
emmrecs
Plugin Expert
Plugin Expert
Posts: 19
Joined: Wed Jan 12, 2005 7:49 pm
Location: Lincolnshire, UK

Problems with PhotoWiz Plugins under Win 7 with PhotoPlus

Postby emmrecs » Sun Jan 24, 2010 5:45 pm

I have all the PhotoWiz plug ins (BW Styler 1.03, Color Washer 2.04, Contrast Master 1.04, Focal Blade 1.07, Light Machine 1.06) running in Serif Photo Plus X3 (latest version) under Windows 7 32 bit.

I have discovered a "problem" which occurs with ALL these plug-ins: if I decide to "cancel" the plug-in, i.e. NOT apply any filter effect, the program immediately crashes. Formerly I ran exactly the same combination of plug-ins and program under XP, without problem.

This is a real annoyance since, sometimes, the "final" decision, having checked the differences any of the plug-ins might make, is that "no change" is best in the circumstances. I suppose it might be possible to "apply" a change and then "undo" it but this is a somewhat "kludgy" workaround.

I've seen an earlier post re DEP, but on my computer DEP is ONLY active for "Windows services etc.."

I would Very much welcome any advice!



UPDATE: I've now discovered that attempting to "OK" any plug-in setting (i.e. apply the change) ALSO crashes the program.

HELP!!!


FURTHER UPDATE: I also have a number of other plug-ins installed, some free (including PhotoFreebies) and some paid for (e.g. Neat Image). None of these cause any problem to PhotoPlus, the effect is applied quickly and successfully.

One thing I have noticed with the PhotoWiz plugs, if I want to OK the change, is that the "crash" seems to occur when the on-screen progress indicator suggests that the effect is "complete", but instead of showing the photo as "effected" the screen becomes transparent and after a few seconds a message appears that PhotoPlus "needs to close". Only once have I received any specific "error message", which was "Memory Access Violation".

Looking at the error report that Win 7 generates consistently shows the "faulting module" as "ntdll.dll". For information I am posting here one complete "error listing";

Problem Event Name: APPCRASH
Application Name: PhotoPls.exe
Application Version: 13.0.0.10
Application Timestamp: 49f9d11f
Fault Module Name: ntdll.dll
Fault Module Version: 6.1.7600.16385
Fault Module Timestamp: 4a5bdadb
Exception Code: c0000005
Exception Offset: 0005205b
OS Version: 6.1.7600.2.0.0.256.48
Locale ID: 2057
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789


I have considered uninstalling and reinstalling PhotoPlus but since my other plugs work properly I am reluctant to do this since the problem does not APPEAR to be with the host application.

emmrecs
Plugin Expert
Plugin Expert
Posts: 19
Joined: Wed Jan 12, 2005 7:49 pm
Location: Lincolnshire, UK

Postby emmrecs » Wed Jan 27, 2010 11:45 am

No-one any ideas on this problem, which is seriously hindering my normal workflow? Harald?

I have tried uninstalling and reinstalling Serif PhotoPlus X3, but the problem remains exactly as before. I suppose the next step could be to uninstall and reinstall ALL my PhotoWiz plugs but it seems unlikely a faulty install would affect them all.

HELP!

HaraldHeim
Plugin Guru
Plugin Guru
Posts: 3354
Joined: Fri Mar 08, 2002 1:00 am
Location: The Plugin Site
Contact:

Postby HaraldHeim » Thu Jan 28, 2010 12:42 am

Thanks for letting me know about the problem. Seems the combination of PhotoPlus X3 and Win 7 causes it.

Unfortunately Serif does not provide trial versions of their applications. But I have PhotoPlus 11 from a magazine cover disk. I will see if I can reproduce the problem with it.

I will let you know.

emmrecs
Plugin Expert
Plugin Expert
Posts: 19
Joined: Wed Jan 12, 2005 7:49 pm
Location: Lincolnshire, UK

Postby emmrecs » Thu Jan 28, 2010 10:01 am

Thanks Harald!

I've also posted about this at the Serif User forum because I'm sure there are others who use PhotoWiz with PhotoPlus. So far, no replies!

If there's anything I can do to help track down the cause of this, please feel free to contact me.

Regards.

Jeff

emmrecs
Plugin Expert
Plugin Expert
Posts: 19
Joined: Wed Jan 12, 2005 7:49 pm
Location: Lincolnshire, UK

Postby emmrecs » Thu Feb 04, 2010 11:20 am


HaraldHeim
Plugin Guru
Plugin Guru
Posts: 3354
Joined: Fri Mar 08, 2002 1:00 am
Location: The Plugin Site
Contact:

Postby HaraldHeim » Thu Feb 11, 2010 9:15 pm


emmrecs
Plugin Expert
Plugin Expert
Posts: 19
Joined: Wed Jan 12, 2005 7:49 pm
Location: Lincolnshire, UK

Postby emmrecs » Fri Feb 12, 2010 10:25 am


HaraldHeim
Plugin Guru
Plugin Guru
Posts: 3354
Joined: Fri Mar 08, 2002 1:00 am
Location: The Plugin Site
Contact:

Postby HaraldHeim » Fri Feb 12, 2010 2:03 pm


emmrecs
Plugin Expert
Plugin Expert
Posts: 19
Joined: Wed Jan 12, 2005 7:49 pm
Location: Lincolnshire, UK

Postby emmrecs » Fri Feb 12, 2010 6:09 pm



Return to “PhotoWiz General”

Who is online

Users browsing this forum: No registered users and 1 guest