Expand mask

FocalBlade specific discussions
madde001
Plugin Power User
Plugin Power User
Posts: 8
Joined: Sun Nov 14, 2004 9:52 pm

Expand mask

Postby madde001 » Mon Dec 06, 2004 3:48 pm

Harald,

In FocalBlade 1.03, when I move the "Expand [mask]" slider to the right in (for example) the X-ray negative mask display mode, the white areas get smaller and the black area gets bigger.

This seems like it's backwards. If you expand the mask, shouldn't the white areas in the X-ray negative mode gradually expand to fill the image?

Seems like this is functioning like a "mask erode" rather than "mask expand" functionality.

(Er, well, I suppose it depends on whether you consider the "edge mask" to be a selection of the edges, or a selection of the non-edges.)

Anyway, is this the way "expand" is supposed to work?

John

HaraldHeim
Plugin Guru
Plugin Guru
Posts: 3324
Joined: Fri Mar 08, 2002 1:00 am
Location: The Plugin Site
Contact:

Postby HaraldHeim » Tue Dec 07, 2004 12:46 pm

Well, if I move the Expand slider to the right, the mask gradually turns into full white in X-Ray Negative display mode. In X-Ray Positive it turns to black.

So I don't really know why it work the other way around on your computer. Are you using a special image?

madde001
Plugin Power User
Plugin Power User
Posts: 8
Joined: Sun Nov 14, 2004 9:52 pm

Postby madde001 » Tue Dec 07, 2004 2:09 pm

Weird. Now it seems to be working correctly. Maybe it had to do with some peculiarity of the image (?!?!?).

Anyway, false alarm.

madde001
Plugin Power User
Plugin Power User
Posts: 8
Joined: Sun Nov 14, 2004 9:52 pm

No, I was right

Postby madde001 » Fri Dec 10, 2004 5:23 pm

Harald,

I found the combination that causes the issue for me.

If the image is in 16-bit/channel RGB mode, and the display option is x-ray negative, then the expand slider appears to operate opposite from the expected sense: the mask image gets blacker.

If you convert the same image to 8-bit/channel, the expand slider in x-ray negative mode makes the mask image get whiter (which is what I expect).

Also, if you look at other mask display options on a 16-bit/ch image, the mask display seems to work in all other cases as I expect. In other words, this seems to be a problem with the x-ray negative mask preview on 16-bit/channel images only.

John

HaraldHeim
Plugin Guru
Plugin Guru
Posts: 3324
Joined: Fri Mar 08, 2002 1:00 am
Location: The Plugin Site
Contact:

Postby HaraldHeim » Sat Dec 11, 2004 5:51 pm

Thanks, John! You are right.

However, the Expand slider still works OK in 16 bit mode. The problems is that the mask isn't displayed correctly in X-Ray Negative mode when using the Expand slider. So it is only a cosmetical issue and doesn't influence the sharpening effect at all.

It will be fixed in the next FocalBlade release.


Return to “FocalBlade”

Who is online

Users browsing this forum: No registered users and 5 guests