Page 1 of 1

light machine problem 1.01

Posted: Mon Feb 13, 2006 12:45 pm
by hampton
I've had light machine working on my new pc for a while. It stopped working the other day with the error message: "can't open the language file: c:\ .... (snip) LightMachine.iniText.txt"

I've tried uninstalling and re-installing a couple of times.

Any thoughts?

many thanks,

Richard

Posted: Wed Feb 15, 2006 3:15 pm
by HaraldHeim
It should still work even with that error message. Anyway, the "Text.txt" at the end of the path is the reason why it can't find the language file. Looks like a bug.

Did you try it again after exiting and restarting Photoshop (or whatever application you use)?

A quick, but dirty fix woul be to rename the file LightMachine.ini to LightMachine.iniText.txt

LightMachine Bug

Posted: Thu Apr 20, 2006 6:29 am
by ajmcdo
I also get this problem on my Mac.
I tried Harald's suggestions but the problem recurred.
The plug-in is difficult to use without language hints.
Wombat

Posted: Thu Apr 20, 2006 9:51 am
by HaraldHeim
Sorry for the problem with LightMachine for Mac that was just released.

Under certain conditions the LightMachine installer seems to lock the languagesLM sub folder inside the LightMachine folder. The same problem also occurs for the Presets sub folder.

To solve it, please do the following:

1. In the Finder go to the folder where you installed LightMachine.

2. Hold down the Alt-key and drag the languagesLM folder to your desktop. That will produce a copy of the folder on the desktop. You will probably have to enter the password for your OS X user name in the process.

3. Drag the original languagesLM sub folder in the LightMachine folder to trash can to delete it.

4. Drag the languagesLM folder from the desktop back into the LightMachine folder.

5. The new folder won't have any access restrictions now.

You have to do the same with the Presets sub folder to allow LightMachine to open the included presets.


There will be a new installer available later today without this problem.

Posted: Thu Apr 20, 2006 1:18 pm
by HaraldHeim
I just uploaded the fixed installation files for LightMachine for Mac. If you experienced the above mentioned problem, please download LightMachine for Mac again from the same download location.

Also get this on Windows XP unless running as Administrator

Posted: Sat May 27, 2006 3:28 am
by menditto
Running LightMachine as local administrator works fine. But running it as unprivilieged account thats just a member of computer-local USERS group gets dialog title ERROR ... "Can't open the language file: languagesLM\EnglishText.TXT. Make sure that this file is available." Granting Full-Control on the parent folder and that file to the account makes no difference.
If you run Sysinternals FileMon, it shows that Photoshop is looking for 'C:\Program Files\Adobe\Adobe Photoshop CS2\Plug-Ins\languagesLM\EnglishControls.TXT'. So if I copy the 'C:\Program Files\LightMachine\languagesLM' folder to the 'C:\Program Files\Adobe\Adobe Photoshop CS2\Plug-Ins' directory, it works.