Page 1 of 1

ColorStyler and Paint.net

Posted: Tue May 15, 2012 6:01 am
by null54
The 64-bit demo is missing the 'Demo' text in the title which prevents PSFilterPdn from replacing the 32-bit version in the menu.

Re: Welcome

Posted: Tue May 15, 2012 12:29 pm
by HaraldHeim
Thanks for letting me know! I fixed it now and uploaded a new demo version.

Re: Welcome

Posted: Fri May 18, 2012 8:54 am
by null54
HaraldHeim wrote:Thanks for letting me know! I fixed it now and uploaded a new demo version.


Unfortunately the new 64-bit demo crashes in filterSelectorStart before the dialog is shown,
although the previous version worked perfectly. :(

Additionally the Repeat Effect command fails for the 32-bit version.

Re: Welcome

Posted: Fri May 18, 2012 11:48 am
by HaraldHeim
I just tested the new 64-bit demo in Paint.net with PSFilterPdn 1.0.4.4 and I do not get a crash.

It could be that the .ini files were corrupted. Can you please send them to me by email, so that I can fix the problem? They are located under
c:\Users\<your username>\AppData\Roaming\ThePluginSite\ColorStyler\
After sending them to me please delete them and try again.

The Repeat Filter command works fine in Photoshop. But I see that it crashes PSFilterPdn or Paint.net with both the 32-bit and 64-bit version of ColorStyler. I will try to debug it.

Re: Welcome

Posted: Fri May 18, 2012 12:11 pm
by HaraldHeim
Paint.net or PSFilterPdn blocks the Visual Studio debugger, so I cannot see the place in my code where the problem occurs. Instead PSFilterPdn displays a message that a protected memory area was overwritten and lists several functions where this happened.

If you can send me a version of PSFilterPdn that gives the control back to the debugger, I can try again.

Re: Welcome

Posted: Fri May 18, 2012 10:38 pm
by null54
Email sent, the Repeat Effect crash was a bug in my code that is fixed in 1.0.4.5.

The debugger fails because Paint.NET and PSFilterPdn are built with managed code, the only way to debug a plugin would be to step into the code when PSFilterPdn is being debugged. :D

Re: Welcome

Posted: Fri May 18, 2012 10:52 pm
by HaraldHeim
Good to hear that. I already suspected that the problem was on your side.

I tested your .ini file here and did not get a crash. Do you still get one?

Re: Welcome

Posted: Fri May 18, 2012 11:00 pm
by null54
Now it does not crash with the old ini files. :roll: