Concern and constructive critisism about your site....

General Remaks about our web site or other things that don't fit in any other forum
RAMWolff
Plugin Newbie
Plugin Newbie
Posts: 1
Joined: Sun Jan 18, 2004 10:10 pm
Location: Belmont. CA USA
Contact:

Concern and constructive critisism about your site....

Postby RAMWolff » Mon Jan 19, 2004 12:21 am

Hi Harold,

I love my plugins, as everyone that uses them does and you provide some wonderful plugins that can't be beat but your Plugin Site is SO slow loading many of the graphically intense pages!! Loading the galleries and other pages proved too much for my Mozilla 1.5 browser and simply do not have the time to test out IE to see if it's just Mozilla. I, like you, want our sites to be nice looking, shiny :D and informative but if a page takes longer than 2 minutes to load your going to loose business. Simple fact out there on the WWW.

While many of have Cable and ADSL, many of us do not. I do not and don't have an extra $30.00 per month to upgrade my 56K modem to one these wonderfully faster connections. Seems the Plugin Site is not optimized for slower connections. I was quite interested in a few of your products and was happy to see lots of links to examples, galleries and screen shots but the images are quite large and with 6 images per page Mozilla gives up and loads about a 1/3 of each image. I know it's the technology of the browser too. Browsers should only load one image at a time, IMHO but they do not do it that way, so if there are 30 images on a page the browser loads as many at once as possible, so if you have 6 images at 75 Kb's or more it just freaks the browser out with a 56K connection. So I gave up. I've spent the last hour trying to view various pages and it's just too frustrating!! In this you have lost a sale!! Sorry to say! :(

I saw on the main page that you announced that you were moving the site to a faster server, blah blah but this does not seem to have happened or if it has the previous server was even slower, which I can't imagine!! :D

Anyway, I'm glad to be here and I'm sorry if my second post here (my first as a guest) seems negative but I only mean for this to be taken as constructive criticism. I hope you can pass this on to your Webmasters or work on making The Plugin Site more optimized for ALL connections, you WILL garner more business in this way, trust me on that!! :)

Thanks for reading this post! :)

Richard ;)
---Wolff On The Prowl---

HaraldHeim
Plugin Guru
Plugin Guru
Posts: 3333
Joined: Fri Mar 08, 2002 1:00 am
Location: The Plugin Site
Contact:

Postby HaraldHeim » Mon Jan 19, 2004 12:04 pm

Thanks for your comments, Richard. The Plugin Site has not yet moved to a new server. It will happen this week. I hope the web site will still be available during most of the time. However, I already uploaded The Plugin Site to a new server, although the domain is not yet connected to it. You can reach it under the following URL:

http://82.165.8.183/

Please try it and let me know if it loads faster from the new server. But it probably won't make a big difference for dial-up connections only for fast DSL or cable connections.

Most pages on The Plugin Site load quite fast, because they don't have many fancy graphics like many other web sites. But of course there are also pages like the Gallery or Product pages which have many large images. It is the purpose of image galleries to have many images. I tried to minimize that by using thumbnails. Concerning some product pages there are probably less thumbnails, so I will try to replace the large images, e.g. the screenshots or example images, with thumbnails linked to the large images if possible. Thanks for bringing that to my attention.

Guest

Postby Guest » Mon Jan 19, 2004 5:54 pm

HaraldHeim wrote:Thanks for your comments, Richard. The Plugin Site has not yet moved to a new server. It will happen this week. I hope the web site will still be available during most of the time. However, I already uploaded The Plugin Site to a new server, although the domain is not yet connected to it. You can reach it under the following URL:

http://82.165.8.183/

Please try it and let me know if it loads faster from the new server. But it probably won't make a big difference for dial-up connections only for fast DSL or cable connections.

Most pages on The Plugin Site load quite fast, because they don't have many fancy graphics like many other web sites. But of course there are also pages like the Gallery or Product pages which have many large images. It is the purpose of image galleries to have many images. I tried to minimize that by using thumbnails. Concerning some product pages there are probably less thumbnails, so I will try to replace the large images, e.g. the screenshots or example images, with thumbnails linked to the large images if possible. Thanks for bringing that to my attention.


Thanks for the response Harold!! :) I will for sure give the address a try and give you feed back. As for the idea of using Thumbnails linked to the images, that is the PERFECT solution for making it easier on those of us with dial up connections. I look forward to the changes!! :)

Richard ;)


Return to “General Comments”

Who is online

Users browsing this forum: No registered users and 3 guests