Batch Processing


ActionsXXL allows you to automatically process multiple images with the help of Photoshop actions as well as many other options.

The Batch dialog can be displayed by clicking the Batch icon at the top of the ActionsXXL panel window, by choosing the Batch menu item from the ActionsXXL panel menu but also by choosing File > Automation Tools > Batch from the main menu of Photoshop Elements.

 

Main Controls

The Apply button starts batch processing. Before you do that you have to check the various tab sheets to make sure that the batch settings of your choice are set. If you changed your mind and do not want to proceed with batch processing, click the Cancel button. To set back all settings to the default, hold down the Alt key and click on the Cancel button, which now turned into a Reset button.

The Save button displays a file dialog for saving the current batch settings to a preset file. Such a batch settings preset (thus the .bsp file extension) can be loaded again at any time later with the Load button to perform another batch process with the same options. When saving such a preset file, best keep the folder that is displayed by default.

Additionally there are six tab sheets with more than 40 batch processing options, which are discussed now.

 

Source

The Source tab sheet lets you define which images will be processed. If you want to process all images that are currently open, choose the Open Images option. To process the selected layers of the current document separately, choose the Selected Layers of Current Document option.

To process specific image files, you can select them in Windows Explorer or any other application and drop them onto the Batch dialog. The Drag'n'Dropped Images option will then be automatically selected. If you keep the mouse cursor over this option for a second, you will see the dropped file names as a tool tip. The dropped files do not have to be from the same folder, they can be from different folders. Each time you drop new files onto the Batch dialog, the old files will be removed, so you cannot accumulate files by multiple drag & drop. The last dropped files are still remembered when returning to the Batch dialog after exiting it, but they will be gone when you restart Photoshop Elements.

Finally, you can also decide to process the image files of a certain folder. To do that click the Select Folder button and choose the folder in the displayed dialog. If you additionally activate the Include All Subfolders check box, even image files from the sub folder of this folder will be processed.

The Override Action 'Open' Commands check box passes the responsibility for opening an image to an action. This means that you have to record an Open step in an action and activate this action on the Process tab sheet (see below), so that the action opens the images during batch processing. ActionsXXL automatically overrides the file path that is recorded in the Open step with the open path of the currently processed file. By activating this check box the Open in Camera Raw option of the Process tab sheet is automatically disabled, because both features are mutually exclusive. The main purpose of this feature is to use special opening options, e.g. Camera Raw settings, for opening all images during batch processing.

The images are automatically closed (except the "None" option is selected on the Destination tab sheet), after they were processed and saved. If you want to continue to manually edit the processed files, you can avoid this with the Do Not Close Opened Images check box. This makes sense if the "Open Images" or "Selected Layers ..." option is activated. However, if a lot of new image files are opened during batch processing and this option keeps them from being automatically closed, then it can happen that the memory is filled and Photoshop Elements continues to work very slowly. This also slows down the batch processing unnecessarily.

 

Destination

The Destination tab sheet allows you to define if the processed images will be saved and if so in which location. If you selected the None option, then each image processed image is opened in Photoshop Elements (if it is not already open) but not saved and closed. So you either have to do that manually yourself or later use the Batch dialog again to save and close these open images. The None option is best used for applying an action to all open documents or layers of one document by activating one of the two first options on the Source tab sheet (Open images, Selected Layers). If you use the third or forth option on the Source tab sheet (Drag'n'Dropped Files, Select Folder), make sure that you do not open too many images this way, otherwise Photoshop Elements may become very slow.

The following three options automatically close a processed images after saving it. So only one image is opened and processed at a time in Photoshop Elements. The Save in same location option saves the processed images in the same folder, which means that they will be overwritten unless you choose another file format and name on the next two tab sheets. The Save in sub folder option lets you enter the name of a sub folder in the text box next to it. As a result the processed images will be saved in a sub folder with that name in the original location of the image files. Both options will not work if you process an open image that was created with File > New Image and not saved yet, because it does not have a file location where it can be saved.

The Select Folder option lets you select another folder for saving the processed images. Click on the Select Folder button to choose one. You can activate the Keep Folder Structure check box to make sure that the sub folders of the source files are replicated in the destination folder. This is the case if you chose Select Folder and activated the Include Subfolders check box on the Source tab sheet provided that there are image files in the sub folders of the source folder. However, the Keep Folder Structure option does not work for dragged and dropped source files, even if they are from different folders. These files are always saved in the main destination folder.

The Override Action 'Save As' Commands check box passes the responsibility for saving images to an action. This means that you have to record an Save As step in an action and activate this action on the Process tab sheet (see below), so that the action saves the images during batch processing. ActionsXXL automatically overrides the file path that is recorded in the Save As step with the save path of the currently processed file. By activating this check box the options on the Format and Auto tab sheets as well as the Play Script feature are automatically disabled, because these features are mutually exclusive. So you have to emulate these disabled features in the action itself in case you need them. The main purpose of this feature is to use special saving options during batch processing. It also allows saving the each image as different file formats by recording multiple Save As steps in the action.

 

Format

The Format tab sheet lets you keep the file format or use another one for saving the files. The File Type combo box offers a Keep File Type option, which does not change the file format of the processed files. The other options let you choose one of the following file types: GIF, JPEG, PNG-8, PNG, PSD and TIFF. The GIF and PNG-8 formats only support 256 colors, JPEG only supports 16 million colors, which are 8 bits per channel. PNG, PSD and TIFF also support 16bits per channel. All of these formats support transparency except JPEG.

The Quality controls can be used to set the JPEG quality from 0 to 12. Zero means very low and 12 means very high. Using values between 9 and 11 should be fine. The Maximize Compatibility check box lets you embed a flattened version of all layers inside a PSD file. This makes the PSD file much larger, but allows viewing it with other programs. The LZW Compression option makes TIFF files smaller, but it takes a bit longer to save and open them.

The Convert to sRGB checkbox converts images with other color spaces to sRGB. You should activate it if you want to upload the processed images on the web. The Convert to 8 Bits per Channel option reduces images with 16 Bits/channel to 8 Bits, which is recommended if you do not want to edit the images further.

The Resize to Fit controls allow you to reduce the size of the processed images. This is quite useful if you want to send the images via email, upload smaller sized versions on the web or create thumbnail versions of the images. To do that you have to activate the check box and enter a width and height figure in pixels. This feature fits all processed images into a rectangle of the entered width and height.

For example, if you process images with landscape as well as portrait orientation and want both types to be equally large, you have to enter the same values for width and height, e.g. 1000 x 1000 px. If you want to place the processed images in a document or web page and only have room for e.g. 800 x 600 pixels, you should be aware that landscape orientated images with a 3:2 proportion will be resized to 800 x 533 whereas portrait orientated images will resized to 400 x 600 pixels. So the portrait orientated image will be much smaller, because it has to be fitted into the height of 600 pixels. If you process square images with the same width and height, they will be resized to the smaller of the two entered values. So in the 800 x 600 case they would be resized to 600 x 600 pixels.

 

Name

The Name tab sheet lets you rename the saved files with the help of a naming pattern consisting of up to six parts. At the top of the tab sheet you can see how the composed file name will look like for the first image and an example file called "MyFile.bmp".

By default the item "Document Name" is set in the first combo box and the item "extension" is selected in the second one. This means that the file name is composed of the existing document name and file extension. As a result the document will keep its filename.

For each of the six combo boxes you can choose one of 17 items or enter your own text. If you enter own text, it will be used literally without changes, unless the text consists of characters that are not allowed in a file name. These illegal characters will be replaced with an _ underscore character.

The 19 combo box items are automatically replaced with the appropriate text as explained here:
Option Explanation

Document Name

Outputs the unchanged file name without extension. If the file name is "Image_2134.jpg", this item will output "Image_2134".

document name

Outputs a lowercase version of the file name without extension. If the file name is "Image_2134.jpg", this item will output "image_2134".

DOCUMENT NAME

Outputs an uppercase version of the file name without extension. If the file name is "Image_2134.jpg", this item will output "IMAGE_2134".

1 Digit Serial Number Outputs a minimum of one digit number starting with the number in the Starting Serial text box. For the first processed image it outputs "1", for the second it outputs "2" and so on. After 10 images a two digits number will be output.
2 Digit Serial Number Outputs a minimum of two digit number starting with the number in the Starting Serial text box. For the first processed image it outputs "01", for the second it outputs "02" and so on. After 100 images a three digit number will be output.
3 Digit Serial Number Outputs a minimum of three digit number starting with the number in the Starting Serial text box. For the first processed image it outputs "001", for the second it outputs "002" and so on. After 1000 images a four digit number will be output.
4 Digit Serial Number Outputs a minimum of four digit number starting with the number in the Starting Serial text box. For the first processed image it outputs "0001", for the second it outputs "0002" and so on. After 10000 images a five digit number will be output.
Serial Letter (a, b, c...) Outputs a lower case letter starting with a. For the first processed image it outputs "a", for the second it outputs "b" and so on. After 26 images two letters are output: "aa", "ab", "ac" and so on.
Serial Letter (A, B, C...) Outputs a upper case letter starting with A. For the first processed image it outputs "A", for the second it outputs "B" and so on. After 26 images two letters are output: "AA", "AB", "AC" and so on.
mmddyy (date) Outputs the current date in the specified format. If today was February 8, 2016, it would output "020816".
mmdd (date) Outputs the current date in the specified format. If today was February 6, 2016, it would output "0208".
yyyymmdd (date) Outputs the current date in the specified format. If today was February 8, 2016, it would output "20160208".
yymmdd (date) Outputs the current date in the specified format. If today was February 8, 2016, it would output "160208".
yyddmm (date) Outputs the current date in the specified format. If today was February 8, 2016, it would output "160802".
ddmmyy (date) Outputs the current date in the specified format. If today was February 8, 2016, it would output "080216".
ddmm (date) Outputs the current date in the specified format. If today was February 8, 2016, it would output "0802".
extension

Outputs the file extension in lower case. The file extension also depends on the File Type setting on the Format tab sheet. If the file name is "Image_2134.jpg", this item will output ".jpg".

EXTENSION Outputs the file extension in upper case. The file extension also depends on the File Type setting on the Format tab sheet. If the file name is "Image_2134.jpg", this item will output ".JPG".
None This item outputs nothing.

 

Process

The Process tab sheet lets you apply up to three actions and one script to the processed images. Additionally you can edit files via Camera Raw.

The Open in Camera Raw feature is only available if "Drag'n'Dropped Images" or a folder was selected on the Source tab sheet. In this case you can decide that no file is displayed in Camera Raw by choosing "None" in the combo box. The option "First raw file & reapply settings" opens the first raw file in Camera Raw and uses the chosen settings automatically for all raw files. If you do not want to apply the white balance settings of the first raw file to all raw files, activate the White Balance As Shot checkbox. This is recommended if the photos were not take at the same time and place. On the other hand if you want to achieve a color effect, then deactivate this checkbox. The options "Each raw file" opens each raw file in Camera Raw, thus allowing an individual adjustment for each raw file. The remaining two options work similar except that JPEG, PNG, PSD and TIFF file are opened in Camera Raw in addition to raw files.

To apply an action activate the appropriate check box, then choose the action set from the first combo box, then choose the actions from the second combo box. You can choose all actions that are available in the actions list of the ActionsXXL panel.

If the Stop for errors check box is deactivated, ActionsXXL displays no error message if an action step causes a problem and continues the batch process. However, in rare cases Photoshop Elements may displays an error message. In such a case simply click OK to continue the batch process. If the Stop for error check box is activated, you will see an error message if an action step causes a problem. If you click Continue, the batch processing will resume. If you click Stop, the batch processing will stop.

You could run a script by including it in one of the actions with the Insert Script panel menu item, but for your convenience you can choose a script file here too. Click on the Select Script button and select a script file in the appearing file dialog. The Run Script check box is then automatically activated.

 

Auto

The Auto tab sheet contains eight check boxes for applying automatic image enhancement features. You can find them on the Enhance menu of Photoshop Elements. The Auto Dehaze and Auto Shake Reduction check boxes are only usable in Photoshop Elements 14 and higher. These enhancements are applied at the end after the three actions and the script were executed.