Panel Menu


The ActionsXXL panel offers a panel menu, which contains almost all of the available features.

Button Mode

The Button Mode panel menu item makes the action tree list vanish and shows all actions as buttons. You can click on each button to play the corresponding action.

So Button Mode is a way to execute actions faster, but it does not offer all features of the normal mode. The bottom icon bar is not available, so you cannot record new actions. Additionally most panel menu items will be inactive, so besides playing actions you can only open new action files, undo an action and perform batch processing.

To exit this mode again simply choose the Button Mode panel menu item again.

 

Floating Window

The menu item "Floating Window" is only available in Photoshop Elements 11 and higher. If you deactivate it, the ActionsXXL panel vanishes and ActionsXXL is displayed in the Actions panel of Photoshop Element. It overlays the original UI of the Actions panel, which gets visible again if you choose the menu items "Floating Window" or "Close" from the panel menu of ActionsXXL.

Using ActionsXXL from the Actions panel has the advantage that it can be docked and does not cover a part of e.g. the document window. The Actions panel can also be made floating, but in such a case it is probably better, to activate the Floating Window mode of ActionsXXL.

 

New Action

The new Action menu item displays a dialog for creating a new action.

In the Name text box you can enter the name of the new action. The Set combo box shows the currently selected set, but you can choose to add the new action to any of the other available sets. The Shortcut combo box offers one of 44 key shortcuts that will trigger the action. See the Key Shortcuts section for more details.

Finally, the Color combo box lets you assign a color to the new action if you want. This color will be used as the background color for the button of your new action in Button mode (See the screenshot above!). You can choose between seven available colors, but can also decide to assign no color, in which case the button of the action will have a standard gray background.

The Record button create a new action and activates recording at the same time. The OK button only creates a new action.

 

New Set

The New Set menu item displays a simple window for entering the name of the new action set. After clicking OK the new set will be added at the bottom of the action list. You can drag and drop it to any other position you prefer.

 

Duplicate

The Duplicate menu item creates an exact copy of the currently selected set, action or step.

 

Delete

The Delete menu item deletes the currently selected set, action or step(s). In the case of a set, action or multiple steps it asks for confirmation. You can use the Ctrl or Shift key to select multiple steps before you trigger this command.

 

Play

The Play menu item plays the currently selected action. If a step is selected, it starts playing the step and continues with the next steps until it reaches the end of the action. Click the Stop icon at the bottom of the panel window (or use the Esc key) to stop the playback before the last step of the action is reached.

 

Record/Stop

This menu item starts action recording. If recording is already enabled, it stops it again. Now you can choose a menu item, press a key shortcut or click somewhere to trigger a function in Photoshop Elements. After the function was performed it will appear as a new item in the action list.

If an action was selected before you triggered a function, the newly recorded step is added as the last step in the action. If an existing step of an action was selected, the newly recorded step is added below the selected step. So you can also record additional steps in an action later and decide where you want to have them inserted. Additionally you can select another step while recording is active in order to record a new step at another position. However, it is not possible to record a new step as the first step if the action contains already other steps. You rather have to drag and drop the step to the first position after recording it.

Please note: Some features of Photoshop Elements are not scriptable, so their settings are not recorded or played back. Additionally some features are unique to Photoshop Elements, so if you try to play an action with them in Photoshop, alternative effects or settings will be applied in Photoshop. These features are: Auto/Adjust SmartFix, Auto Smart Tone, (Auto) Haze Removal, (Auto) Shake Reduction, Adjust Color Curves and Convert to Black and White.

 

Record Again

The Record Again menu items works just like double clicking the label of an action step. It plays the selected step again and lets you edit its dialog settings. You have to click OK on the dialog, otherwise the step will not be updated with the new settings. If a certain step has no dialog (e.g. Copy, Delete Layer, Invert), the step is only played and not recorded again.

 

Insert Menu Item

This menu item allows you to record items from the top menu as well as the menus of other panels, which are normally not recordable, because they do not trigger an image processing functionality. Examples for such menu items are File > Print, Edit > Preferences > General, View > Zoom In, Window > Histogram and Color Swatches panel menu > New Swatch.

When selecting this menu item, action recording will be activated, in case it is not already enabled. To stop recording these special menu items, simply stop recording by clicking the Stop icon or choosing the Record/Stop panel menu item. Then start recording again to only record the standard menu items. So this feature is only active until you stop recording.

 

Insert Stop

The Insert Stop item of the panel menu lets you enter a message that will be displayed when the action is played. For entering this message you will see a new dialog with a text box. Enter your message in the text box and activate the Allow Continue check box if you want to give the option to continue action playback after the message was displayed.

When the stop step was added to the action list of the ActionsXXL panel window, it has a dialog icon next to it if you previously entered a message in the text box or activated the Allow Continue check box. If you click on the icon and thus deactivate the dialog icon, it means that the action playback is interrupted without displaying a message.

 

When the inserted stop with activated dialog icon is played, you will see a message box like the ones above. If you activated the Allow Continue check box, there will be a Continue button on the message box, which will immediately continue playing the rest of the action steps. Otherwise it is only possible to click the Stop button, which will interrupt the action playback. This allows the user of the action to perform some manual steps before he clicks on the play icon to resume the playback of the action.

To edit the message again either double click the Stop item in the action list or choose the Record Again panel menu item.

 

Insert Conditional

The Insert Conditional menu item lets you add an action step that plays another action depending on a property of the current document. For more details please see the Conditional Feature section.

 

Insert > Path

The Insert > Path menu item inserts the current path as a step into the action. When playing back this step, the path is recreated. This feature also works if a shape layer or a layer with a vector mask is selected, but the action step only recreates the path and not the shape layer or vector mask itself. Please use Insert > Shape for shape layers. For a vector mask you additonally have to record Layer > Vector Mask > From Path, which is available if you have ElementsXXL installed.

 

Insert > Shape

The Insert > Shape menu item inserts the current shape layer as two steps into the action. When playing back these steps, the shape layer is recreated.

 

Insert > Action

The Insert > Action menu item adds a new step to the current action, which plays back another action. In the appearing dialog you can select the action that is played.

 

Insert > Script

The Insert > Script menu item opens a file dialog for selecting a script file with the file extension .jsx. After you selected such a script file, a new action step is added, which run this script.

 

Insert > Adjustment Layer

The Insert > Adjustment Layer menu item inserts an action step, which recreates the currently selected adjustment layer including its settings. This can be useful if you try to record the settings of an adjustment layer, but it does not work out. Photoshop Elements normally informs ActionsXXL about the changed settings in the modeless panel of an adjustment layer right before another command is triggered, e.g. a new adjustment layer is created or a filter is applied. However, this does not always work, e.g. if another layer is selected instead. So this menu command is an option to compensate this problem of Photoshop Elements.

 

Action/Set Options

If a set is currently selected, this menu item is named "Set Options" and displays the dialog shown at the "New Set" menu item above. If an action is currently selected, the menu item is called "Action Options" and displays the dialog shown at the "New Action" menu item above. So you can edit the set name and the action properties with this menu item.

Unlike the New Action dialog the Action Options dialog does not let you choose a new set for the current action. But you can edit the action name, shortcut and the button color.

 

Playback Options

The Playback Options menu item allows changing the speed at which actions are played back. Here are explanations for the available options:
Option Explanation

Maximum

This is the default option that plays action 30% faster than the Accelerated option and only creates one item with the action name in the History panel. You do not see in the document window which steps the actions performs - you only see a progress window.
Accelerated

This options plays back actions like the Photoshop Elements Actions panel, but you additionally see a progress window. This option is slower than the Maximum option and it creates a new item in the History panel for each action step. You see that something is going on in Photoshop Elements, but usually the image is only updated after the action finished.

Step By Step Unlike the Maximum and Accelerated options this option updates the document window after every action step, which makes it run actions slower, but at the same time you see what the actions steps do.
Pause for x seconds In case the Step By Step option runs the action too fast for you to observe what it does, you can use this option. It makes a pause of 1, 2 or more seconds after each action step.
Stop after every Step If you want to check out each action step more closely, this option interrupts the action playback after each step. To execute the next action step, simply click on the play icon again.


ActionsXXL offers two more options than Photoshop ("Maximum" and "Stop after every Step"). The Step by Step option of ActionsXXL plays actions approximately twice as fast as the same option in Photoshop. For emulating the Step by Step option of Photoshop with ActionsXXL, you have to select the Pause option and enter "1" for seconds.

The Action panel of Photoshop Elements 11 and higher does not offer playback options, so it always runs actions with the Accelerated option. So with ActionsXXL's Maximum option you can play actions 30% faster and avoid that the History panel is cluttered with new items.

Please note: Although creating a single history item is a big advantage of the Maximum playback option, some action steps require other history items in order to work properly. So ActionsXXL temporarily switches the playback mode from Maximum to Accelerated to make such actions work nevertheless. Thus it is possible that multiple history item are created in Maximum mode in case it is unavoidable for playing back the action correctly.

The Off option of the Show Progress feature displays no progress window while an action is played. The default Simple option shows a progress window with the action name and a progress bar. The Full option displays a progress window with the name of each action step plus a progress bar.

 

Clear All Actions

This menu item deletes all sets and actions from the ActionsXXL panel window after asking for confirmation.

 

Load Actions

The Load Actions menu item opens a file dialog for opening one or more .atn files. Each file contains one action set. The new set of each the file is then displayed in the ActionsXXL panel. You can also open action files by dragging and dropping them on the ActionsXXL window.

ActionsXXL also supports .atn action files that were created by Photoshop. A few special action steps from these file may not work when played back with ActionsXXL, but ActionsXXL supports more action steps than the Actions panel of Photoshop Elements 11 and higher. If you have ElementsXXL installed, more actions steps from Photoshop are supported.

 

Load

The Load sub menu allows loading various action files. The Default Actions menu item loads the actions, which are displayed by default in the Actions panel of Photoshop Elements. The PS Default Actions menu item loads the default actions of Photoshop. As both commands would have the same result in Photoshop Elements 6-10, you only see the first of both menu items there.

The Photo Effects menu item loads the action that are visible as thumbnails on the Effects tab of the Effects panel of Photoshop Elements. Thus you can modify them and use them for batch processing. The Harrys Actions menu item opens a set of actions, which were installed together with ActionsXXL.

Photoshop offers the "Reset Actions" and "Replace Actions" menu items, which are more or less superfluous. With ActionsXXL you can reset actions by choosing "Clear All Actions" and Load > Default Actions. Replacing actions can be done with "Clear All Actions" and "Load Actions".

 

Save Actions

The Save Actions menu item saves the currently selected action set as an .atn file. A file dialog shows up, where you have to choose the file location and enter the name of the new action file. The .atn file format only allows to save one set of actions and not multiple ones, so a set of actions corresponds to one .atn file. Neither is it possible to save a single action to an .atn file. The whole set is always saved.

An .atn file can be later opened again with the Load Actions panel menu item. You can also send the .atn file to other people or offer it for download. The saved .atn file can also be opened and played in Photoshop.

 

Batch

The Batch menu item shows the Batch dialog, which allows automatically processing multiple images or files with actions and other functions. For more information see the Batch Processing section.

 

Help

This menu item show the manual of ActionsXXL.

 

Close

This menu item will make the ActionsXXL panel disappear. To make it appear again choose File > Automation Tools > ActionsXXL from the main menu of Photoshop Elements.