User Interface

Panel Window


ActionsXXL consists of a panel window, which allows you to record, manage and play Photoshop actions among other things.

The Panel Window

Das ActionsXXL panel window is initially displayed as a floating window with its own title bar. Double click the title bar to collapse or expand it again. You can do the same by clicking on the >> symbol in the title bar. Clicking the x symbol (or choosing the Close item from the panel menu) closes the ActionsXXL window. To display it again please go to File > Automation Tools > ActionsXXL in the menu of Photoshop Elements.

You can resize the ActionsXXL panel by moving the mouse cursor to the edges of the window. Then you will see an arrow cursor, which lets you enlarge or shrink the window if you hold down the mouse button and drag. To move the ActionsXXL panel simply drag its title bar.

Apart from the title bar the panel window consists of three sections: a button bar at the top, an action list and a button bar at the bottom.

In Photoshop Elements 11 and higher you can integrate ActionsXXL into the Actions panel. To do that deactivate the menu item "Floating Window" from the panel menu. Then make sure that "Expert" is activated in the center of the top bar and choose Window > Actions from the main menu of Photoshop Elements. This shows the Actions panel, which now incorporates the ActionsXXL window.

To open action files in ActionsXXL you use the Load Actions command from the panel menu, but you also open them by dragging and dropping them on the ActionsXXL window.

 

The Action List

Photoshop actions are part of an action set, which is displayed in the action tree list of the ActionsXXL panel. Action sets are identifiable by the yellow folder icon and can hold a large number of actions. Actions have a gray document icon and can contain a large number of action steps. Actions steps always have a check box at the left. So the action list on the ActionsXXL panel consists of a three-fold hierarchy: Sets, actions and steps.

Sets as well as actions can be collapsed or expanded by clicking their triangle symbol or by double clicking their label. Steps cannot be expanded, you can only deactivate them with their check box. A step with a deactivated check box is not played when you click the Play icon. Additionally you can click on the icon of each step item to define if a dialog is shown when playing this step or not. An empty square icon means that no dialog will be displayed. However, you should be aware that not all steps can in fact display a dialog. So even if the dialog icon is active for a step it does not necessary mean that a dialog is displayed. For example a "Delete Layer" or "Paste" step cannot show a dialog, because there is not dialog available for these functions.

Double clicking a step item lets you play and record the step again at the same time. For example if you double click a step called "Levels", the Levels dialog will be displayed with the recorded settings. You can now change the settings and click OK to replace the old settings in the action step. Again this only works for steps with dialogs. Double clicking steps like "Delete Layer" or "Set Selection" will play them, but as they have no dialogs, you cannot change any settings.

You can move an action from one set to another or move a step from one action to another by drag and drop. You can also change the position of a set, action or step this way. Simply position the mouse cursor over the set, action or step, hold down the left mouse button, move the mouse to the new position and release the mouse button. If you hold down the Alt key while dragging an item, it will not be moved but duplicated.

To rename a set or action select it and click on it again. Now an edit box appears for changing the name. Finally hit the Enter key or click somewhere else on the panel window to commit the change. Alternatively you can also use the "Set Options" or "Actions Options" panel menu items for renaming. Steps cannot be renamed as their name is tied to their functionality.

To display the parameters of an action step, keep the mouse cursor one second above it. As a result you will see tool tip, which lists the parameters and their values. If "n/a" appears, it means that there are no parameters.

 

The Top Icons

Clicking the first icon at the top (as well as clicking on the Batch item of the panel menu) shows the Batch dialog. For more information see the Batch Processing section.

The second icon lets you undo the steps of last played or recorded action. ActionsXXL remembers the last step in the History panel that was selected before you started recording or playing an action. Once you click on the Undo icon this previous step will be selected again. This is quite handy if you want to start recording an action again from the beginning or if you did not like the effect of the action that you just played.

Finally, the third icon at the right panel edge displays the panel menu as can be seen above. The panel menu contains many functions which are not available as icons, e.g. loading or saving actions or inserting special action steps. For more information see the Panel Menu section.

 

The Bottom Icons

The icons at the bottom of the panel window perform the following functions (from left to right): Stop, Play, Record, New Set, New Action, Insert Conditional and Delete.

Once you started playing or recording an action you can stop it again by clicking the Stop icon. Before you can play an action you have to select one in the action list. If a set is selected, the first action of that set is played. You can also select a step if you do not want to play the top most steps of an action. Clicking the Play icon will then run it and the subsequent steps. As long as the action runs you can stop it with Stop icon (or the Esc key). When it is finished, it will automatically stop.

To record an action you also have to select an action or step icon before clicking the Record icon. If you want to create a totally new action, you have to click on the New Action icon or choose "New Action" from the panel menu. If you selected an action with existing steps, a new recorded step will be added as the last step. If you selected a step when clicking the Record icon, the new recorded step will be added right after the selected step. To stop recording again click the Stop icon.

The New Set icon creates a new set after asking for a name. The New Action icon creates a new action in the currently selected set. Clicking the Insert Conditional icon displays a dialog for selecting a condition as well as one or two actions that will be played if the condition is met or not met. For more information on conditions see the Panel Menu section.

Finally the Delete icon deletes the currently selected set, action or step(s). If a set, action or multiple steps are selected, you have to confirm the deletion. You can use the Ctrl or Shift key to select multiple steps before you click this icon.