Step by Step

 

Playing an Action

1. Open an image in Photoshop Elements.

2. If the action that you want to apply is not already displayed in ActionsXXL, click on the menu icon at the top right of the ActionsXXL panel window to display the panel menu. On the panel menu choose Load Actions and on the appearing file dialog choose your action file.

3. Select the action in the ActionsXXL panel window and click the play icon.

4. If the action displays a dialog or message, click the OK or Continue button. Some actions display a message with a Stop button. In this case you have to do some manual step and then click on the play icon again to continue with the action.

5. After the action finished have a look at the result.

 

Playing an Action in Button Mode

1. Open an image in Photoshop Elements.

2. If the action that you want to apply is not already displayed in ActionsXXL, click on the menu icon at the top right of the ActionsXXL panel window to display the panel menu. On the panel menu choose Load Actions and on the appearing file dialog choose your action file.

3. To switch to Button Mode open the panel menu again and click on the Button Mode menu item. Now all actions are displayed as buttons. Click one of the buttons to run an action.

4. If the action displays a dialog or message, click the OK or Continue button. Some actions display a message with a Stop button. In this case you have to do some manual step and then click on the action button again to continue.

5. After the action finished have a look at the result.

 

Recording an Action

1. Open an image in Photoshop Elements - unless you want the action to open or create an image itself.

2. If you have not already created your own actions set, click the set icon at the bottom of the ActionsXXL panel window. Alternatively click on the icon at the top right of the panel window and choose "New Set" from the panel menu. On the appearing dialog enter a name for your set, e.g. "John's Actions".

3. Create a new action by clicking the action icon at the bottom of the ActionsXXL panel window. Alternatively choose "New Action" from the panel menu. On the appearing dialog enter a name for your action, e.g. "My Special Effect 1". You can also choose a set where the action will be placed, a key shortcut for triggering the action and a color for button mode.

4. Click the record icon at the bottom of the ActionsXXL panel window. Alternatively choose "Record" from the panel menu.

5. Now perform the steps in Photoshop Elements that you want to record to an action. After each step you will see a new step item added to your action in the ActionsXXL window. If a certain menu item cannot be recorded, choose the "Insert Menu Item" item from the panel menu and try again.

6. If you recorded a step with wrong settings, click the delete icon at the bottom of the ActionsXXL panel window to remove the step and try again.

7. When you have finished, click the stop icon next to the record icon.

8. Now you can click the undo icon at the top of the ActionsXXL window and play your recorded action. To play the actions more slowly or to make the actions stop after each step try the "Playback Options" panel menu item.

9. If you want to change the settings of a recorded step, double click it in the action list in the ActionsXXL window. Then change the dialog settings and click OK. If you want to change the position of a step you can simply drag and drop it to another position.

10. If you want to display a message at a certain point in your action, choose the "Insert Stop" panel menu item.

 

Saving an Action

1. After your recorded or modified one or more actions and are satisfied with the result, it is a good idea to save it. You can save only one set of actions into an .atn file, so it is good if all actions of this set are ready to be saved. Otherwise create a new set and drag and drop only the action(s) that you want to save into it.

2. Select the action set that you want to save. You can select the set item itself, but it is already fine if there is a selection anywhere inside the set.

3. Click on the icon at the top right of the ActionsXXL panel window and choose "Save Actions" from the panel menu.

4. In the appearing file dialog choose a folder and enter a file name.

5. Your action set is now saved as an .atn file and can be loaded again in ActionsXXL at any time.

 

Batch processing open images or layers with Actions

1. If you want to apply the same image processing steps to multiple open images or multiple layers in Photoshop Elements, you can record these steps as described above and use the Batch dialog to apply them.

2. If you want to apply an action to multiple layers, select these layers in the Layers panel. Hold down the Ctrl or Shift key to select multiple layers. If you want to apply an action to multiple open documents, make sure that only these documents are open. Close all other documents that you do not want to process.

3. Run the Batch command by clicking on the batch icon at the top of the ActionsXXL panel window, by choosing File > Automation Tools > Batch or by selecting the "Batch" panel menu item.

4. To make sure that no previous batch settings are activated that you may not want to use, hold down the Alt key and click on the Cancel button, which now turned into a Reset button.

5. On the Source tab sheet of the Batch dialog activate the "Open Images" or the "Selected Layers ..." radio button.

6. Switch to the Destination tab sheet and activate the "None" option. This makes sure that the open documents are not saved and closed.

7. If you want to resize the documents or convert them to sRGB or 8 Bits/channel, then activate the appropriate options on the Format tab sheet.

8. On the Process tab sheet activate one of the Run Actions check boxes, select the set of your action from the first combo box at the right and the actions itself in the second combo box. This will apply your action.

9. If you want to apply an automatic enhancement to your documents, activate the appropriate check box on the Auto tab sheet.

10. To use these batch settings again later click the Save button and enter a name for them. To open them again later, use the Load button.

11. Now click the Run button to start the processing. If there is a problem, you can press the Esc key to stop the batch processing at any time.

 

Batch processing files with Actions

1. If you want to batch process image files in Photoshop Elements, best close all open documents. Make sure that the action(s) that you want to apply to the image files are displayed in the ActionsXXL window.

2. Run the Batch command by clicking on the batch icon at the top of the ActionsXXL panel window, by choosing File > Automation Tools > Batch or by selecting the "Batch" panel menu item.

3. To make sure that any previous batch settings are activated that you may not want to use, hold down the Alt key and click on the Cancel button, which now turns into a Reset button. If you want to use batch settings that you saved to a file, use the Load button.

4. On the Source tab sheet click the Select Folder button and choose the folder that contains your image files. If you want to process images files from sub folders of the selected folder, activate the "Include All Subfolders" check box. Alternatively you can select the image files in Windows Explorer and drag and drop them onto the Batch dialog.

5. Switch to the Destination tab sheet and activate one of the three bottom radio buttons. The None option will only open the image files, but not save and close them. It is probably best if you save the processed files in a sub folder with the "Save in sub folder" option or if you select a new folder with the Select Folder button. The "Save in same location" option overwrites the original files if you do not select another format or name on the next two tab sheets, so you should usually only use it if you already work with duplicates of the original files.

6. Switch to the Format tab sheet. If you want to keep the current file format of files, use the "Keep File Type" option. Otherwise choose one of the other file formats from the File Type combo box. Choose the prefered file format options below the combo box. If you want to resize the images, e.g. to create thumbnails for low resolution versions, activate the Resize to Fit check box and enter the maximum new width and height.

7. Switch to the Name tab sheet. If you want to keep the name of the files, make sure that "Document Name" is visible in the first combo box and "extension" in the second. Otherwise choose another option or enter a text in the combo boxes. At the top you see an example of how the first processed file with a file name of "MyFile.bmp" would be renamed.

8. On the Process tab sheet you can apply up to three actions and a script to the images. Additionally you can edit none, the first or all images with Camera Raw.

9. If you want to apply an automatic enhancement to your documents, activate the appropriate check boxes on the Auto tab sheet.

10. To use these settings later again, click the Save button and enter a name for the settings.

11. Now click the Run button to start the processing. If there is a problem, you can press the Esc key to stop the batch processing at any time.