FAQ

 

Does ElementsXXL turn Photoshop Elements into Photoshop?

ElementsXXL adds many features to Photoshop Elements that are only available in Photoshop, e.g. running actions and scripts, several new adjustment layers and filters, smart objects, smart filtering, layer groups, layer masks, channels, vector masks, paths, 16-bit/channel conversion, quick mask mode and soft proofing. So ElementsXXL actually bridges a large part of the gap between Photoshop Elements and Photoshop.

But there are a few limitations in Photoshop Elements that ElementsXXL cannot overcome (at least not in the latest version): CMYK mode, video editing and 3D functionality. If you do not need them, you should be quite happy with Photoshop Elements and ElementsXXL.

 

What is the difference between ElementsXXL and other products that extend Photoshop Elements?

The big thing about ElementsXXL is that it fully integrates into the user interface of Photoshop Elements by adding new menu items, key shortcuts, icons and various dialogs. ElementsXXL starts up together with Photoshop Elements, so it does not need to be run manually. ElementsXXL feels like an upgrade to Photoshop Elements and not like a plugin or external tool.

Other products that try to extend the functionality of Photoshop Elements have to be executed by clicking a button or menu item. They are limited to a single dialog that blocks the user interface or consist of simple actions. So they are not as intuitively and easy to use as ElementsXXL. They do not provide the rich features of ElementsXXL.

There is no other product for Photoshop Elements that adds new Layers panel features, lets you run Photoshop scripts directly, lets you so many apply third-party smart filters, offers Brush, Channels, Path and Properties panels, features a Calculations dialog, enhanced Curves, multiple Warp effects, allows color profile conversion, enables saving CMYK image files, gives you 16-bit versions of existing filters, allows processing 16-bit images with smart filters and layers and offers 29 additional tools for retouching 16-bit images - only to mention a few things.

ElementsXXL supports all versions of Photoshop Elements (for Photoshop Elements 1-10 older versions of ElementsXXL are provided) and does not need to be purchased separately for each Photoshop Elements version.

 

Are there any differences when using ElementsXXL in different versions of Photoshop Elements? Which version of Photoshop Elements should I be using?

We highly recommend using ElementsXXL with version 13 to 2018 of Photoshop Elements, because most features are available for them. Photoshop Elements 15 and 2018 miss some features, e.g. the pen, mixer brush, ruler and slice tools whereas Photoshop Elements 13 and 14 miss other features, e.g. 12 Enhance/Adjustments smart filters, an Opacity slider on the Color Lookup dialog and a Photoshop version of the Curves filter. Photoshop 13 additionally misses the New Guide Layout dialog and New Guides from Shape command. In Photoshop Elements 12 among other things you have no Combine Shapes, Puppet Warp, Perspective Warp, Perspective Crop features, no Content-Aware options, linked smart objects, no Color Lookup adjustment layer, less 16-bit options, the Warp feature only works on 8-bit images and Color Range has less features. Photoshop Elements 11 is similar to version 12, but the Puppet Warp works (8-bit images only) and the "Log History to Metadata" feature is available.

Here is a detailed list of the differences between Photoshop Elements 11 to 2018:

Photoshop Elements 11 & 12:

+ Pen, Freeform Pen, Add Anchor Point, Delete Anchor Point, Convert Point and Direct Selection tools
- The Warp feature works only on images with 8-bit per channel.
- The Combine Shapes, Perspective Warp and Perspective Crop features are not available.
- The Color Range dialog has less features
- No Content-Aware option for various dialogs and tools
- No support for linked smart objects
- No Color Lookup adjustment layer
- Not possible to use vector masks with 16-bit images
- No support for layer rotation, transformation and scaling for 16-bit images
- 12 smart filters from the Enhance/Adjustments menu are not available
- No Rasterize Layer Styles menu item
- No "Windows LCD" and "Windows" anti-alias type options
- The "Automatic" and "Preserve Details" options of Fit Image do not work
- New Guide Layout dialog & New Guides from Shape command are missing
- No "Save in Background" option
- No Photoshop version of the Curves filter

Photoshop Elements 11:

+ The "Log History to Metadata" feature works.
- The Puppet Warp tool works only on images with 8-bit per channel.


Photoshop Elements 12:

- The "Log History to Metadata" feature does not work.
- The Puppet Warp tool is not available.

Photoshop Elements 13 - 2018:

+ The Puppet Warp tool works on images with 8-bit and 16-bit per channel.
+ The Warp feature works on images with 16-bit per channel.
+ The Combine Shapes, Perspective Warp and Perspective Crop features are available.
+ The Color Range dialog offers all features
+ Content-Aware options on various dialogs and tools
+ Support for linked smart objects
+ Color Lookup filter and adjustment layer
+ Support for vector masks for 16-bit images
+ Support for layer rotation, transformation and scaling for 16-bit images
+ "Windows LCD" and "Windows" anti-alias type options
+ Fit Image offers new "Automatic" and "Preserve Details" options
+ Rasterize Layer Styles
+ "Save in Background" option
- The "Log History to Metadata" feature does not work.

Photoshop Elements 13 & 14:

+ Pen, Freeform Pen, Add Anchor Point, Delete Anchor Point, Convert Point and Direct Selection tools
- The Color Lookup dialog has no Opacity slider
- 12 smart filters from the Enhance/Adjustments menu are not available
- No Photoshop version of the Curves filter

Photoshop Elements 13:

- Missing New Guide Layout dialog & New Guides from Shape command

Photoshop Elements 14:

+ New Guide Layout dialog & New Guides from Shape command

Photoshop Elements 15 & 2018:

+ The Color Lookup dialog offers an Opacity slider
+ 12 new smart filters from the Enhance/Adjustments menu
+ Photoshop version of the Curves filter
+ New Guide Layout dialog & New Guides from Shape command
- No Pen, Freeform Pen, Add Anchor Point, Delete Anchor Point, Convert Point and Direct Selection tools
- No Mixer Brush, Ruler and Slice tools

 

How do I know which features are added by ElementsXXL and which are part of Photoshop Elements?

ElementsXXL adds a blue background to its icons, buttons and menu items. To remove this colorization, please go to File > Automation Tools > ElementsXXL and deactivate the "Colorize Icons & Menu Items" check box.

ElementsXXL also provides various new key shortcuts. You can see a list of its key shortcuts under File > Automation Tools > ElementsXXL > Key Shortcuts. Additionally you can check out the manual on the menu under Help > ElementsXXL Help. All features of ElementsXXL are mentioned and explained there in detail.

 

Where do I find the new features of version 5 of ElementsXXL in Photoshop Elements?

Here is a list of the new features in ElementsXXL 5 and where they are located:

File > Export > Quick Export as PNG/JPEG/GIF
Edit > Copy Special > Copy Layer Styles
Edit > Copy Special > Copy Shape Attributes
Edit > Copy to Document (Preview feature)
Edit > Paste Special > Paste Outside Selectio
n
Edit > Paste Special > Paste Into Place
Edit > Paste Special > Paste Into
Edit > Paste Special > Paste Outside
Edit > Paste Special > Paste Layer Styles
Edit > Paste Special > Paste Shape Attributes

Edit > Fill Layer/Selection (Own dialog with new features)
Edit > Tools > Pen Tool (Photoshop Elements 11-14)
Edit > Tools > Freeform Pen Tool (Photoshop Elements 11-14)
Edit > Tools > Direct Select Tool (Photoshop Elements 11-14)
Edit > Tools > Add Anchor Point Tool (Photoshop Elements 11-14)
Edit > Tools > Delete Anchor Point Tool (Photoshop Elements 11-14)
Edit > Tools > Convert Point Tool (Photoshop Elements 11-14)
Edit > Tools > History Brush (Preview feature)
Edit > Preferences > ElementsXXL
Image > Rotate > Custom (Color Adaptation option)
Image > Rotate > Free Rotate Layer (Color Adaptation option)
Image > Rotate > Straighten Image (Content-Aware) (Color Adaptation option)
Image > Rotate > Straighten and Crop Image (Content-Aware) (Color Adaptation option)
Image > Transform > Free Transform / Skew / Distort / Perspective(Color Adaptation option)
Image > Transform > Warp (Color Adaptation option)
Image > Transform > Perspective Warp (Color Adaptation option)
Image > Resize > Image Size (Own dialog with new features)
Image > Resize > Canvas Size (Color Adaptation option)
Image > Resize > Fit Image (Preserve Details method)
Image > Resize > Scale (Color Adaptation option)
Image > Render > Add 16-bit Layer (Preview feature)
Image > Render > Render 16-bit Document / to Lightroom (Improved)
Image > Apply Image (Preview feature)
Enhance > Auto Lens Correction
Enhance > Auto Smartfix (16-bit/channel support)
Enhance > Adjust Smartfix (16-bit/channel support)
Enhance > Adjust Color > Remove Color Cast (16-bit/channel support)
Enhance > Adjust Color > Adjust Color for Skin Tone (16-bit/channel support)
Enhance > Adjust Color > Color Lookup (16-bit/channel support & works as smart filter in Photoshop Elements 15/16)
Enhance > Adjust Color > Vibrance (works as smart filter in Photoshop Elements 15/16)
Enhance > Adjust Color > Color Balance (works as smart filter in Photoshop Elements 15/16)
Enhance > Adjust Color > Channel Mixer (works as smart filter in Photoshop Elements 15/16)
Enhance > Adjust Color > Selective Color (works as smart filter in Photoshop Elements 15/16)
Enhance > Adjust Lighting > Levels (works as smart filter in Photoshop Elements 15/16)
Enhance > Adjust Lighting > Curves (More features & works as smart filter in Photoshop Elements 15/16)
Enhance > Adjust Lighting > Exposure (works as smart filter in Photoshop Elements 15/16)
Enhance > Convert to Black & White (16-bit/channel support)
Enhance > Black & White (new features & works as smart filter in Photoshop Elements 15/16)
Enhance > Reduce Noise
Enhance > Micro Contrast

Layer > Quick Export as PNG/JPEG/GIF
Layer
> New Adjustment Layer > Black & White (new features)
Layer > Type > Windows LCD (Photoshop Elements 13-16)
Layer > Type > Windows (Photoshop Elements 13-16)
Layer > Type > Font Preview Size
Layer > Vector Mask (can be applied to shape, type, fill and adjustment layers now)
Layer > Rasterize > Type
Layer > Rasterize > Shape
Layer > Rasterize > Smart Object
Layer > Rasterize > Styles (Photoshop Elements 13-16)
Layer > Stamp Down / Stamp Group / Stamp Layers
Layer > Merge Group
Filter > Adjustments > Photo Filter (works as smart filter in Photoshop Elements 15/16)
Filter > Adjustments> Invert (works as smart filter in Photoshop Elements 15/16)
Filter > Adjustments> Posterize (works as smart filter in Photoshop Elements 15/16)
View > New Guide Layout

View > New Guides from Shape
Window > Smart Filter
Layer panel context menu (up to 23 new menu items)
Crop tool > Tool Options > Color Adaptation
Crop tool > Tool Options > Presets
Perspective Crop tool > Tool Options > Color Adaptation (Photoshop Elements 15/16)

Some other new features work in the background are not directly linked to a certain control or menu item.

 

Does ElementsXXL really allow using layers with 16-bit images in Photoshop Elements?

This question cannot be simply answered with a yes or no. ElementsXXL offers a so-called Render features, which provide a workaround for the missing layer support for 16-bit images in Photoshop Elements. Adding and editing the layers still takes place in 8-bit mode, but you can render a 16-bit image from all layers once you are finished.

It works this way: You open a 16-bit image, convert it to a 8-bit document with 16-bit image data embedded in a smart object and then start adding layers, adjustment layers and smart filters. You can save this 8-bit document and continue working later. Finally, you render all layers of the 8-bit document to a 16-bit image. The 16-bit image contains no layers, just the flat end result. You can go back to the 8-bit document with the layers, edit it again and recreate a 16-bit image from it any time.

You may ask if the resulting 16-bit image really contain true 16-bit depth or not. If you do not make one big mistakes, the answer is yes. The mistake would be add a fully opaque image layer that covers the whole image, which degrades the rendered 16-bit image to 8-bit. To avoid this you instead have to add a smart object with embedded 16-bit data via the "Add 16-bit Layer" command. If you only have the image in 8-bit available, you can set the opacity of the layer to less than 100%, use another blend mode than "Normal" or otherwise make the layer semi-transparent. Then the 8-bit and 16-bit data is blended, which means that the 16-bit depth is retained. In some other cases, e.g. by adding a textured text or using an opaque healing brush on small image areas, it is neglectable that these small areas of the 16-bit image have an actual bit depth of 8-bit. ElementsXXL provides a "Check Bit Depth" command, which calculates the actual bit depth of an image. With its help you can make sure that the bit depth was not degraded.

As you can see the Render features require only a few small compromises, but they ultimately grant a much greater freedom when processing 16-bit images.

 

I have a non-English version of Photoshop Elements. Can I use ElementsXXL with it?

Yes, definitely. 95% of the features of ElementsXXL are automatically translated to the language of Photoshop Elements. For example, if you use a Spanish version of Photoshop Elements, all menu items and almost all dialogs of ElementsXXL are in Spanish. Only the Preferences dialog and a few messages are only available in English and German.

There are only English and German manuals for ElementsXXL, but you can read about most ElementsXXL features in the manual of Photoshop or on the Photoshop Help page - both of which are available for various languages. You can simply search for a certain term, e.g. the name of a menu item, in the Photoshop PDF manual or on the Photoshop Help page. Here are the Photoshop Help pages (where you can also find the Photoshop manual) in all languages that Photoshop Elements supports: Czech, German, English, Spanish, French, Italian, Japanese, Dutch, Polish, Portuguese, Russian, Swedish, Turkish, Chinese, Taiwanese.

If you want to look up some ElementsXXL features in the English manual and you have a non-English version of Photoshop Elements installed, you can activate the "Force English Localization" check box on the ElementsXXL Preferences dialog. After restarting Photoshop Elements, the ElementsXXL items will be shown in English language.

Alternatively you can enter the term together with "Photoshop" in Google, e.g. "Photoshop Auto-Align Layers". Then you will find a lot of information and tutorials about it.

 

Sometimes the Auto-Blend Layers feature of ElementsXXL does not work. What can I do about it?

In some cases the Auto-Blend Layers feature may not have enough memory to perform its task. Here are some measures to make it work anyway:

1. Exit all other applications.
2. Close all other documents in Photoshop Elements.
3. Choose Edit > Clear > All to free more memory in Photoshop Elements.
4. Go to Edit > Preferences > Performance and increase the Memory Usage to 90 or 95%.
5. Reduce the number of layers that are processed with Auto-Blend Layers.
6. Reduce the image size of the document that contains the layers.
7. If you run Windows 32-bit, upgrade to Windows 64-bit. This will double the amount of memory that Photoshop Elements can use (from 1.6 GB to 3.2 GB RAM).
In Photoshop Elements 13 (and higher) you can even use almost all of your RAM under Windows 64-bit. If you use Photoshop Elements 11 for MacOS X, update to version 12 or higher in order to have more RAM available.