Menu Items

 

File Menu

 

Browse in Organizer

Supported by Photoshop Elements 11 and higher
Requirements: None
Added in ElementsXXL 1.0

This item in the File menu basically provides the same functionality as the organizer icon in the lower left part of the Photoshop Elements window. It makes it easier to activate the organizer instantly. Moreover, it is equivalent to the "Browse in Bridge" menu item in Photoshop.

 

Open > As

Added in Photoshop Elements 12 and higher, already available in Photoshop 11
Requirements: None
Added in ElementsXXL 3.0

The Open As command lets you open files that have no file extension or a wrong or unknown file extension. By choosing the Camera Raw item on the file dialog, you can also open JPEG, TIFF, PNG and PSD files with Camera Raw. However, using the Open In Camera Raw command is easier to use for this purpose.

 

Open > In Camera Raw

Added in Photoshop Elements 11, already available in Photoshop 12 and higher
Requirements: None
Added in ElementsXXL 3.0

This feature lets you open non-raw files in Camera Raw. JPEG, TIFF, PNG and PSD files are currently supported by Camera Raw in addition to the many flavors of raw files, which are opened with Camera Raw anyway.

 

Open > As Smart Object

Supported by Photoshop Elements 11 and higher
Requirements: None
Added in ElementsXXL 1.0, extended in 4.0

Open As Smart Object displays a file dialog for opening an image. But unlike the normal Open command it automatically embeds the opened image document (including its layers) into a smart object. For more information on smart objects, please see the Convert to Smart Object item of the Layer Menu. Since ElementsXXL 4 this command preserves 16-bit image data from PSD, PNG und TIFF files as well as 8-bit layers inside the smart object.

 

Open > As Linked Smart Object

Supported by Photoshop Elements 13 and higher
Requirements: None
Added in ElementsXXL 4.0

The Open > As Linked Smart Object menu item displays a file dialog for opening an image. This image is then added as a linked smart object in a new document. Unlike normal smart objects these are linked to a source file and can be updated when the source file changes. For more information on linked smart objects, see the Layer > Smart Object sub menu of the Layer Menu. However, this command produces non-linked smart objects from camera raw files, because Camera Raw files cannot be changed.

 

Open > As Camera Raw Smart Object

Supported by Photoshop Elements 11 and higher
Requirements: None
Added in ElementsXXL 3.0

This command embeds an image into a smart object and displays Camera Raw for editing it. At the moment JPEG, TIFF, PNG, PSD and raw files files are only supported. You can edit the Camera Raw settings later again by double clicking the smart object thumbnail in the Layers panel.

To create a Camera Raw smart object for other file types, please do the following: Open them normally, choose Layer > Smart Object > Convert to Smart Object and then Layer > Smart Object > Edit with Camera Raw.

 

Export > Quick Export as ...

Supported by Photoshop Elements 11 and higher
Requirements: An image has to be opened.
Added in ElementsXXL 5.0

The Quick Export as PNG/JPEG/GIF command immediately saves the current image according to the settings on the Export page of the ElementsXXL Preferences. If you hold down the Ctrl key and click on this menu item, the ElementsXXL Preferences dialog appears with the Export page selected.

 

Export > HTML

Supported by Photoshop Elements 11 and higher
Requirements: An image has to be opened and at least one slice should be created.
Added in ElementsXXL 2.0

The Save HTML command works like the Save For Web menu item if no slice is available. If you created at least one slice (see the Slice Tool), it produces a .html file and saves the document as multiple image files. The Slices features let you turn a Photoshop Elements document into a web page and the Save HTML menu item saves this web page.

 

Export > PDF

Supported by Photoshop Elements 11 and higher
Requirements: An image has to be opened
Added in ElementsXXL 3.0

The Save PDF command saved the current document in PDF format. After entering the file name in a file dialog the Save PDF window is displayed. Here you can choose between many PDF format options.

At the top you can choose between various presets of commonly used settings. The Standard combo box offers Version 1 to 4 of the PDF format and the Compatibility option determined with which version of Adobe Acrobat/Reader the PDF file can be opened. The lower the version number in both cases, the more backward compatible the PDF file will be. But this can also mean that the PDF file will be larger.

Under General the Preserve Photoshop Editing Capability check box ensures that a second copy of the document will be included in the PDF file, which will then be used when opening it again in Photoshop or Photoshop Elements. This also makes the PDF file much larger. The Embed Page Thumbnails check box adds thumbnails for each page of the PDF document. As Photoshop Elements documents only consist of one page, this does not increase the size file by much. The Optimize for Fast Web Preview option makes sure that the PDF is already displayed in a web browser even if it is not fully downloaded. The View PDF After Saving check box displays the PDF file in your system's default PDF viewer.

In the Compression group you can choose to deactivate downsampling or choose between three options for downsampling the image to a certain ppi (pixels per inch) value when it is saved as the PDF file. We recommend using the Bicubic option. The second ppi value at the right of "For Images Above:" only triggers the downsampling if the image exceeds a certain ppi value.

The Compression combo box offers four options for compressing the image data in the PDF file. The None option avoids compression, which results in a much larger file. ZIP is a lossless compression type, but slows down the saving and PDF opening process. JPEG is the most common used option, because it produces smaller PDF files without too much quality loss. The JPEG 2000 option produces even smaller files with less quality loss, but again slows down the saving and PDF opening process. When JPEG and JPEG 2000 are selected you can also choose an Image Quality option. For JPEG 2000 you can also change the Tile Size of the compression algorithm. The Convert 16 Bit/Channel Image to 8 Bits/Channel check box makes sure that the image data in the PDF is 8 bits per channel, thus making the file smaller.

Under Output activate the Convert To Destination check box to choose an new profile for the image data in the PDF by using the Destination combo box. By choosing Working CMYK the image is converted to CMYK data with the help of the profile that is selected under Edit > Color Settings > Working Spaces > CMYK. This way you can use the PDF file for prepress tasks, e.g. by opening it in Adobe InDesign. The Include Destination Profile check box makes sure that the original color profile of the image or the Destination profile is embedded in the PDF file. The next two text boxes let you enter some information about the Output Conditions and Registry Name.

Finally click Save PDF to save the file or click Cancel to stop the whole thing.

 

Export > Color Lookup Table

Supported by Photoshop Elements 11 and higher
Requirements: An RGB image has to be opened
Added in ElementsXXL 4.0, accelerated in ElementsXXL 5.0

The Save Color Lookup Table command lets you save a Lookup file in 3dl, cube or csp format, which can be opened and applied with the Color Lookup filter or adjustment layer. To create such a lookup file ElementsXXL either needs to compare the orginal image with a modified image or read a lookup pattern that was added to the image before it was modified.

The former approach means that you need an unmodified background layer and one or more adjustment layers, which apply an effect, in a document. You have to make sure that the "Read from Lookup Pattern (top left)" check box is deactivated, otherwise the lookup file will contain nonsense values. This method only works with 8-bit documents, because adjustment layers are not supported for 16-bit images in Photoshop Elements.

The later approach demands that you add a lookup pattern with the Image > Add Color Lookup Pattern menu item to an unmodified image and then apply filters (and maybe adjustment layers) to it. On the Color Lookup Table dialog you have to activate the "Read from Lookup Pattern (top left)" check box to make it work, otherwise a lookup file that applies no changes or only a partial effect will be produced. Creating a working lookup file is possible as long as the lookup pattern was not removed or is hidden by a layer. This method also works with 16-bit images, which means that the created lookup files will include more precise color values.

On the Color Look Table dialog you have to enter the name of the look up file and a copyright notice, e.g. your name. Next you have to decide on the number of grid points that you want to sample. The default value of 16 means that 16 * 16 * 16 = 4096 color values will be sampled, which results in a lookup file size of 50 - 100 K. The smallest possible value samples 7 * 7 * 7 = 343 color values and the highest grid point value samples 128 * 128 * 128 = 2,097,152 color values. It makes not much sense to use a value of 128, because it will produce a file of 25-60 MB size and loading this file into the Color Lookup dialog will make you wait for up to a minute until it is processed. We recommend using grid points between 16 and 32.

In the Format combo box you can choose the format of the lookup file. The 3DL format produces files that are only half as large as the CUBE and CSP files, but CUBE and CSP file contain slightly more precise color values if they were sampled from a 16-bit image. However, you will not see a visual difference.

In the Options group you can see a "Read from Lookup Pattern (top left)" check box, which was already discussed above. But please note that if this check box is activated you have to use the same grid points value and format type as on the Add Color Lookup Pattern dialog, otherwise the created lookup file will contain nonsense values. Both values are shared between both dialogs, so this should no be a problem normally.

The Save in Presets folder check box saves the lookup file in the preset folder of the Color Lookup filter and adjustment layer after clicking OK. However, you need to restart Photoshop Elements to see the saved preset on the on the 3DLUT File combo box of the Color Lookup dialog. This feature is only available in Photoshop Elements 13 and higher. If the Save in Presets folder check box is not activated or available and you click OK, a file dialog will appear for choosing the location where the lookup file will be saved.

 

Place Linked

Supported by Photoshop Elements 13 and higher
Requirements: An image has to be opened
Added in ElementsXXL 4.0

The Place Linked menu item works similar to the Place command. It lets you open an image file that will be placed as a smart object in the current document. But in this case the smart object is a linked smart object. Linked smart objects are automatically updated when their source file changes - provided that the documents with the linked smart objects are open in Photoshop Elements when the source file is updated. Otherwise the smart objects have to be updated manually after opening their file again. For more information see the Layer > Smart Object sub menu.

 

Scripts

Supported by Photoshop Elements 11 and higher
Requirements: Depend on the script

Added in ElementsXXL 1.0

The Scripts sub menu lets you run script files that carry out various operations in Photoshop Elements. Scripts can be edited in a text editor. They are highly adaptable, provided that you have some programmer skills. Scripts are either delivered with Photoshop Elements as well as other Adobe applications or can be downloaded from various web sites. Please note that not all available scripts are compatible with Photoshop Elements, so you may experience an error message and some scripts may not work.

The Scripts sub menu can also be accessed by clicking the Scripts button on the control bar in the upper left part of the window.


Browse

The Browse menu item displays a file dialog for choosing a script file. After choosing it the script file is automatically executed.


Scripts Menu Items

The script menu displays scripts from up to two different folders. Click on these scripts to run them.

If you previously opened a script with the Browse menu item, then the scripts that are located in the same folder are displayed at the top of the Scripts sub menu. Below a separation line appear scripts from the Scripts folder of Photoshop Elements, which are located in the Presets sub folder of the Photoshop Elements folder.

 

Actions

Supported by Photoshop Elements 11 and higher
Requirements: Depend on the action, usually an image has to be opened

Added in ElementsXXL 1.0

The Action sub menu lets you run action files that carry out various operations in Photoshop Elements. Actions are either delivered with Photoshop Elements as well as Photoshop or can be downloaded from various web sites. Actions can be recorded in Photoshop, but not in Photoshop Elements. In Photoshop Elements 11 and 12 you are also able to access actions from the Actions panel.

There are some .atn action files in the Required sub folder of the Photoshop Elements folder as well as at c:\ProgramData\Adobe\Photoshop Elements\12.0\Photo Creations\photo effects\. If you are using an older version, replace "12.0"in this file path with your version number of Photoshop Elements. You can load these actions with the Load Actions command.

Some action may display a message that a certain command is not available. By clicking the Continue button you can nevertheless run the action, which will result in success in many cases.

The Actions sub menu can also be accessed by clicking the Actions button on the control bar in the upper left part of the window.


Load Actions

The "Load Actions" menu item displays a file dialog for choosing an action file. After choosing it, the actions of the action file are displayed on the Actions sub menu.


Clear Actions

The "Clear Actions" menu item deletes all actions displayed on the Actions sub menu in case you already opened too many actions. This will make your workflow more neat if you want new actions displayed at the top of the Actions menu.


Reset Actions


The "Reset Actions" menu item restores or appends the default actions. A message box will ask you about replacing the current actions. Click Yes to clear all action and load only the default ones. Click No to append the default actions to the existing action or click Cancel to abort the operation.


Actions Menu Items

The Actions menu provides actions which are loaded in Photoshop Elements. Clicking on one of these actions runs them.