Other Features

 

Icons, Buttons & Tool Options

ElementsXXL adds two menu items and two sub menus to the File menu of Photoshop Elements.

 

Tool Bar Icons

Supported by Photoshop Elements 11 and higher
Added in ElementsXXL 1.0, extended in 2.0

 

In Photoshop Elements 11 (and higher) two icons are added at the bottom of the tool bar below the two color boxes: the Quick Mask icon and the Tools icon. You can click on the Quick Mask icon to start editing in Quick Mask Mode and click again to exit this mode. If you double click it, Quick Mask Mode is activated and at the same time the Quick Mask Options dialog is displayed. Clicking on the Tools icon displays the Tools sub menu of the Edit menu, which contains various additional tools that are activated by ElementsXXL.

 

Tool Options

Supported by Photoshop Elements 11 and higher
Added in ElementsXXL 4.0, extended in 5.0

ElementsXXL adds three new check boxes as well as a presets combo box to the Tool Options window of the Crop tool. Deactivating the Delete Cropped Pixels check box (hidden by the combo box list in the screenshot above) makes sure that cropped image areas are only hidden and not deleted. You can make these hidden image areas visible again by using the Image > Resize > Reveal All menu item. The new Content-Aware check box automatically fills blank or transparent image areas with image content in Photoshop Elements 13 and higher. These blank or transparent image areas occur if a part of the crop frame is placed outside the image borders. An activated Color Adaptation check box tells the content-aware algorithm to adjust colors in the process, so it only triggers a variation of the content-aware algorithm.

The new presets combo box offers several new presets and also lets you save and delete your own crop presets. The No Restrictions item lets you freely draw a crop frame on the image. The Use Photo Dimensions item fills the W and H text boxes with the current image size, so that the cropped area is upsized to the original pixel dimension. The Original Ratio item displays a crop frame and locks its proportions to makes sure that the cropped image has the same proportions as the original image. The next six combo box items offer popular width/height ratios and the subsequent four items offer popular photo print sizes in inch or centimeter depending on your system settings.

Finally, the New Crop Preset item displays a dialog for entering a name for the crop preset. A preset is only saved if at least the W and H text boxes contain values. For saving a print size as a preset you should also enter something into the Resolution text box, e.g. 300 Pixels/Inch for the usual resolution. To save an image proprotion or ratio as a preset, first choose one of the ratio presets and then change the values in the W and H text boxes. That is necessary, because Photoshop Elements by default converts entered ratio values into pixel values. Choosing a ratio presets sets the W and H text boxes to "ratio mode".

Newly saved presets are shown on the preset combo box (above the New Crop Preset item) and can be applied from there. To delete one or all of them again you can use the Delete Crop Preset item. This displays a dialog where you can choose the preset that you want to delete or choose "All Crop Presets" to delete all of your presets.

ElementsXXL also adds a Content-Aware check box to the tool options of the Transform tool, which can be invoked with the Ctrl + T key shortcut or various menu items on the Rotate, Transform and Resize sub menus of the Image menu. By activating the Color Adaptation check box the content-aware algorithm adjust colors in the process, so it basically uses a different content-aware algorithm. The Content-Aware feature only works in Photoshop Elements 13 and higher.

In Photoshop Elements 15 and higher Content-Aware and Color Adaptation check boxes are also added to the Tool Options window of the Perspective Crop tool.

You will also find a More Options button on the Tool Options window of 22 different tools that are use a brush, e.g. the Quick Selection tool, Selection Brush tool, Healing Brush tool, Brush tool, Clone Stamp, Sponge / Dodge / Burn tools, Eraser tool or the Pencil tool. Clicking this button displays the Brush panel and provides many new options for adjusting the brush that is used by the tool.

Finally, a Flow slider is added to the Tool Options window of the brush, clone stamp, pattern stamp and eraser tools. This slider has a similar effect as the Opacity slider, but it defines how much color flows from the brush tip onto the canvas. Flow provides a finer control than Opacity when building up a line with multiple strokes.

 

Control Bar Buttons

Supported by Photoshop Elements 11 and higher
Added in ElementsXXL 1.0, extended in 2.0

 

Three buttons, called Script, Actions and Render, which display a menu, are added to the control bar. They are located at the left hand side of the control bar.

These buttons display the Scripts and Actions sub menu of the File menu as well as the Render sub menu of the Image menu. They allow you to much faster access and run scripts and actions as well as process 16-bit images with smart filters and layers. For more information on the items on these menus see the Scripts, Actions and Render sub menus.

 

Layers Panel Features

Supported by Photoshop Elements 11 and higher
Added in ElementsXXL 1.0, extended in 2.0, 3.0 und 4.0

Depending on the version of Photoshop Elements two or three icons are added to the top or bottom of the Layers panel. Additionally double clicking different areas on a layer item triggers certain functions.

Here is a screenshots that illustrates which features ElementsXXL adds to the Layers panel and which areas can be clicked:

Layer Mask Icon

ElementsXXL adds a layer mask icon to the Layers panel of Photoshop Elements 8. In Photoshop Elements 9 and higher such an icon is already available and ElementsXXL only supplies additional functionality to it.

Clicking the layer mask icon adds a layer mask to the selected layer. If a selection is present when clicking it, the selection is drawn into the layer mask. If a selection is present and you hold down the Ctrl key when clicking the layer mask icon, then a vector mask is created instead of a layer mask. If you (additionally) hold down the Alt key, an inverted selection is drawn into the layer mask or added as a vector mask.

See the Layer Mask and Vector Mask sub menus of the Layers menu page for more information.


Layer Style Icon

Click on the "fx" icon to display the Style Settings dialog for adding or editing layer effects. If the background is currently selected, you will be asked to convert it into a layer before continuing.


Layer Group Icon

This icon is only added by ElementsXXL in Photoshop Elements 8-14. In Photoshop Elements 15 and higher it is already available. Clicking this icon embeds all selected layers into a layer group. If a layer group is already selected when clicking it, the layer group is dissolved and the embedded layers are ungrouped again. In Photoshop Elements 8-14 you have to ungroup in order to edit the layers of a layer group. Then you can create the layer group again. See the Group/Ungroup Layers commands of the Layers menu for more information.


Smart Object Icon

You can click the smart object icon to embed the selected layers into a smart object. If the selected layer is already a smart object and you click this icon, then the Smart Filters panel appears. If one or more smart filters are already applied, then the Edit tab sheet of the Smart Filters panel appears.

To select the filter mask of a smart object or to deselect it again, hold down the Alt key and click on the Smart Object icon. Alternatively you can also click on the thumbnail in the Layers panel to deselect the filter mask. If "Filter Mask" is written in the tab button or title bar of the current document, you can be sure that the filter mask is selected.


Smart Filter Symbol

If a smart object has at least one smart filter applied, you can see a filter symbol at the right hand side of its layer item in the Layers panel. Click it to display the Edit tab sheet of the Smart Filters panel. There you can edit the smart filters.


Adjustment Layer Icon Menu

The new adjustment layers that were added to the Layer > New Adjustment Layer sub menu by ElementsXXL are also added to the menu of the adjustment layer icon.


Layer Thumbnail

Double clicking the thumbnail of an adjustment layer that was added by ElementsXXL makes a dialog with the filter settings appear (just like it does for native adjustment layers added by Photoshop Elements itself). On this dialog you can change the settings of the adjustment layer as described on the Layer Menu page.

You can deselect the filter mask of a smart object if you click the the thumbnail of a smart object, which has one or more smart filters applied to it. If you hold down the Alt key and click on the thumbnail, the filter mask is displayed as a grayscale image and can be edited that way. Click again on the smart object thumbnail (with or without the Alt key) to see the image again.

If you double click the thumbnail of a smart object, you can edit the content of the smart object. If the smart object has a raw file embedded, the Adobe Camera Raw dialog shows up and you can readjust its settings. If the smart object contains a normal image file, the contents of the smart object is opened as a new document. After editing, choose File > Save from the menu to commit the changes to the smart object and then close the document. Read the Edit Contents menu item for more information.

Double click the thumbnail of a normal layer to display the Channels panel. Double clicking the layer mask or vector mask thumbnail makes the Properties panel appear.

 

Layers Panel Context Menu

Supported by Photoshop Elements 11 and higher
Extended in ElementsXXL 5.0

If you right click somewhere or on a layer item in the Layers panel, a context menu with various menu items appears. Depending on the selected layer ElementsXXL adds up to 24 of its own commands at the bottom of this menu. This usually allow you to access them quicker than using the Layer menu at the top.

Here is a list of the commands that are displayed:

 

History Panel Menu

Supported by Photoshop Elements 11 and higher
Added in ElementsXXL 1.0

The menu of the History panel offers a "History Options" item, which displays the History page of the ElementsXXL Preferences dialog. These options can be used to change the behavior of the history panel. For more information see the section about Preferences > ElementsXXL.