Image Menu

 

Rotate > Custom

Supported by Photoshop Elements 13 and higher
Requirements: An image has to be opened.
Extended in ElementsXXL 4, extended in 5.0

ElementsXXL adds Content-Aware and Color Apatation check boxes to this dialog. The Content-Aware check box fills transparent or blank areas with image content after clicking OK. An activated Color Adaptation check box tells the content-aware algorithm to adjust colors in the process, so it only triggers a variation of the content-aware algorithm.

 

Rotate > Free Rotate Layer, Transform > Free Transform / Skew / Distort / Perspective, Resize > Scale

Supported by Photoshop Elements 13 and higher
Requirements: An image has to be opened.
Extended in ElementsXXL 4, extended in 5.0

All of these menu items trigger the Transform tool. ElementsXXL adds Content-Aware and Color Apatation check boxes to the Tool Options window of the Transform tool. The Content-Aware check box fills transparent or blank areas with image content after applying the tool. An activated Color Adaptation check box tells the content-aware algorithm to adjust colors in the process, so it only triggers a variation of the content-aware algorithm.

 

Rotate > Rotate Layer ... / Flip Layer ...

Supported by Photoshop Elements 13 and higher
Requirements: An 16-bit image has to be opened.
Extended in ElementsXXL 4

Normally these five menu items can only be used with images with 8-bit per channel. ElementsXXL allows applying them to 16-bit images too.

 

Rotate > Straighten (and Crop) Image (Content-Aware)

Supported by Photoshop Elements 13 and higher
Requirements: An 16-bit image has to be opened.
Extended in ElementsXXL 4, extended in 5.0

The non-content-aware version of these two menu items automatically straightens (and crops) images by detecting uneven lines. As a result the image will be rotated, which produces blank or transparent image areas. ElementsXXL adds content-aware versions of these two menu items, which automatically fill the blank or transparent areas with image content.

An dialog with a Color Adaptation check box is displayed by this command. The Color Adaptation check box makes the content-aware algorithm adjust colors if needed. Sometimes the result may look better with or without the check box activated.

 

Transform > Warp

Supported by Photoshop Elements 8 and higher
Requirements: An image has to be opened.
Added in ElementsXXL 3.0, extended in 4.0 and 5.0

The Warp function offers 16 methods for bending an image. The Custom option displays a 16-point-grid over the image. By dragging each of the 16 handles, you can precisely define which areas of the image will be warped. If there are transparent layer areas or if a selection is available, the Warp tool displays its mesh around it/them and does not place it over the whole image as usual.

The 15 other warp option from the Warp combo box apply different warp shapes, which can be edited with the three sliders and a check box. The Bend slider changes the warp shape and the H and V sliders squeeze the ends of the warp shape horizontally and vertically. The Flip check box rotates the warp shape by 90 degrees thus switching between horizontal and vertical orientation. The Content-Aware check box fills transparent areas with image content after applying the Warp tool. An activated Color Adaptation check box tells the content-aware algorithm to adjust colors in the process, so it only triggers a variation of the content-aware algorithm.

Click the Reset button to start from scratch. It will switch the 16-point-grid to its original state and reset the sliders to their default values. Once you are finished click the green check mark to exit. The red circle and the Esc key will undo the operation.

 

Transform > Perspective Warp

Supported by Photoshop Elements 13 and higher
Requirements: An image has to be opened.
Added in ElementsXXL 3.0, extended in 4.0 and 5.0

The Perspective Warp function lets you bend the image perspectively. This feature has two modes. First of all you draw a rectangle on the image, which activates Layout mode. Now use the four handles of the rectangle to modify the source rectangle. If the image is perspectively wrong, you should adjust the source rectangle to follow the tilted lines in the image. If the image has a correct perspective and you want to change that, best leave the source rectangle as it is.

To continue to Warp mode either hit the Enter key or click the Warp button on the Perspective Warp dialog. Now you will see the destination rectangle which is the same rectangle that you drew. If you move its four corner handles, you will immediately see the effect of the perspective warp feature. The three small buttons on the Perspective Warp dialog let you adjust the destination rectangle vertically, horizontally or both. The Reset button will undo your adjustments and lets you start again. The Content-Aware check box fills transparent areas with image content after applying the Perspective Warp tool. An activated Color Adaptation check box tells the content-aware algorithm to adjust colors in the process, so it only triggers a variation of the content-aware algorithm.

You can switch between Layout and Warp mode with the appropriate buttons any time and readjust both rectangles. To apply the effect hit the Enter key or click the green check mark. Cancel it with the red circle or the Esc key.

 

Auto-Align Layers

Supported by Photoshop Elements 11 and higher
Requirements: At least two layers have to be selected in the Layers panel.
Added in ElementsXXL 1.0

The Auto-Align Layers function lets you align two or more very similar photos in order to combine them to one image. This is quite useful if you want to combine multiple shots of the same subject, e.g. a group of people, photos taken with different exposure or depth of field or if you want to create a panorama image from multiple shots.

Firstly, you need to place each photo on a different layer. Then you select all layers in the Layers panel and run the Auto-Align Layers command. After the layers were aligned, you can use layer masks to only add the best parts of each layer to the final image.

In the Auto-Align Layers dialog you can choose between different options for changing the projection of the images. The Auto option tries to find the best option for the corresponding image layers. It chooses between Perspective or Cylindrical projection. When creating a panorama it may choose the Perspective method, which is not always the best choice, so we recommend activating the Cylindrical option. For stacked images it is best to keep the Auto option.

The Perspective option choose a layer as the reference image (usually the middle layer) and perspectively stretches the other layers to match it. The Cylindrical option avoid the “bow-tie” distortion of the Perspective option by placing the layers on an unfolded cylinder. The Spherical option is meant for photos with wide fields of view, thus it spherically transforms the layers. The Collage option aligns the layers without changing the shape of the layers. Finally, Reposition makes sure that matching image contents overlap by simply repositioning the layers, so no transformation is applied.

An activated Vignette Removal check box tries to remove shadows at the corners of the layers. Geometric Distortion compensates barrel, pincushion or fisheye distortions.

 

Auto-Blend Layers

Supported by Photoshop Elements 11 and higher
Requirements: At least two layers have to be selected in the Layer panel.
Added in ElementsXXL 1.0

The Auto-Blend Layers function enables you to put different images together in order to create either a panoramic scenery with seamless transitions or stack images one above the other in order to increase the depth of field of macro photos. The individual photos have to be present as layers and these layer have to be selected for this functionality to work.

If you are trying to blend panorama photos or want to combine macro shots taken without a tripod it is advisable that you apply the Auto-Align Layers feature beforehand in order to have the layers correctly positioned. Otherwise the result may not be as expected.

The Auto-Blend Layers dialog offers two blend methods to select. If you want to create a panorama images, activate the Panorama option. If you want to increase the depth of field, choose "Stack Images". An activated Seamless Tones and Colors checkbox grants smooth transitions and colors.

 

Trim

Supported by Photoshop Elements 11 and higher
Requirements: The image has to contain a colored frame or a layer with transparent pixels.
Added in ElementsXXL 1.0

The Trim menu item allows you to cut away the colored or transparent areas at the borders of the image. This is useful if you scanned a photo and want to remove extraneous areas.

The Trim dialog box lets you select three options that the trimming is based on. You can either trim away transparent pixels on a layer or pixels of a certain color. The color can be picked up from the top left or bottom right corner. The four check boxes determine, where the empty areas are to be trimmed.

 

Resize > Image Size

Supported by Photoshop Elements 11 and higher
Requirements: An image has to be opened.
Extended in ElementsXXL 5.0

ElementsXXL replaces the Image Size dialog of Photoshop Elements with a dialog of its own which looks and works like the one from Photoshop CC. This dialog also makes new resampling options available and is more straight-forward to use. If you nevertheless prefer the original dialog, you can access it via the Classic button or activate the Image Size check box under Edit > Preferences > ElementsXXL > Classic.

The Image Size label shows how much RAM the new image will occupy in contrast to the current RAM size. The Dimensions label displays the final image size. Its menu icon lets you choose between various units from pixels, percent, inches, cenimeters, milimeters to more exotic units like points, pica and columns. The selected unit will be used to display the image site.

The Fit To combo box offers various image size presets as well as option to load, save and delete your own image size presets. There is also an Auto-Resolution option which displays a dialog.

The Width, Height and Resolution text boxes let you enter the final image size and resolution. At the right hand side of the text boxes are combo boxes for switching to other units like percent, inches etc. If the Resample check box is activated, the actual pixel dimensions of the image will be changed. If it is deactivated, only the resolution value is changed, but the pixel dimension remain the same.

With an activated Resample check box you can see a bracket sign at the left hand side of the Width and Height text boxes, which means that the image proportions remain the same and the width or height are automatically adjusted accordingly. If you click on the knot symbol of the bracket, you can make the bracket disappear thus making the width and height independent of each other. Now the image proportions are not protected anymore. If the Resample check box is deactivated the bracket will span the Width, Height and Resolution text boxes, which indicates that they dependent on each other. If you enter a value in one of the three text boxes, the other two are adjusted accordingly.

The Resample combo box at the right hand side of the Resample check box offers various resampling methods, also called interpolation algorithms. The Automatic option automatically choose the best method for the current settings. There are two methods specifically meant for enlargements, one meant for image size reductions and three methods that work fine for either. The Preserve Details options is meant for big enlargements, e.g. 400% and higher, and also offers a Reduce Noise option that avoids that noise pixel become visible when enlarging the image. It also works fine for reducing the image size.The Bicubic Smooth option produces smooth gradients for enlargements, but also blurs smaller details. Bicubic Sharper sharpens the image after changing the image size which works best for reducing the image size. If you prefer to apply the sharpening yourself, better use the Bicubic option.The Bicubic option is the best all-purpose method and works fine for reductions as well as image enlargements ip to 400%. We do not recommend using the Bilinear option for photos, because it is less effective than Bicubic. It may have its uses for computer graphics. The Nearest Neighbor method produces a very coarse result, so better only use it if you really want to produce a pixelation effect via image enlargement.

If your document contains layers with layer styles, keep the Scale Styles check box activated, otherwise the style effect will not be resized and appear too small or too big.

 

Resize > Canvas Size

Supported by Photoshop Elements 13 and higher
Requirements: An image has to be opened.
Extended in ElementsXXL 4
and 5.0

The Canvas Size dialog allows increasing or decreasing the image dimensions without altering existing image pixels. It only adds or crops a certain amount of pixels to/from the image. ElementsXXL adds Content-Aware and Color Apatation check boxes to this dialog. The Content-Aware check box fills transparent areas with image content after clicking OK. An activated Color Adaptation check box tells the content-aware algorithm to adjust colors in the process, so it only triggers a variation of the content-aware algorithm.

 

Resize > Fit Image

Supported by Photoshop Elements 11 and higher
Requirements: An image has to be opened
Added in ElementsXXL 4.0, extended in ElementsXXL 5.0

The Fit Image dialog lets you resize an image and change its dpi setting. Unlike the Image Size dialog you only define a maximum size here, which will be used as the bounding rectangle in which the image will be fit. This has the advantage that you do not need to calculate the actual image size yourself, e.g. if you want to place an image into an empty space in another document or if you want multiple image with different proportions to have similar image dimensions.

Please enter the maximum width, height and resolution in the appropriate text boxes. The combo boxes at their right-hand side let you switch between various units, e.g. pixel, inch, cm, megapixel or pixel per inch or pixel per cm. If you choose Megapixel, you can only enter one instead of two values for the width and height. The width and height will then be calculated according to the proportions of the current image.

The final width and height in pixels is displayed in the Image Size label below the three text boxes. The Method combo box lets you choose between seven methods for resampling the image. Automatic is the recommended choice. The Preserve Details option enables the Reduce Noise slider, which determines how much noise is reduced while resizing the image.

The Scale Styles check box decides if layer effects (also called style settings) will be scaled too.

 

Resize > Reveal All

Supported by Photoshop Elements 11, already built into Photoshop Elements 12 and higher
Requirements: A layer has to be selected
Added in ElementsXXL 4.0

The Reveal All command make hidden layer areas visible again. These layer areas moved outside the image borders, e.g. with Canvas Size, Scale, Rotate, Transform or similar features.

 

Render

Supported by Photoshop Elements 11 and higher
Requirements: Requires a 16-bit image
Added in ElementsXXL 2.0, extended in 4.0 and 5.0

The Render commands enable you to process an image with 16 bits per channel with the help of smart filters, adjustment layers and other layer types. Photoshop Elements normally does not support smart filters and layers for 16-bit images, but ElementsXXL makes it possible by working in 8-bit mode and later rendering the special 8-bit document to a 16-bit image.

There is also a Render menu button on the control bar for accessing all Render commands quickly.


Prepare 8-bit Document

 
The original 16-bit document   The prepared 8-bit document with a smart object that has the 16-bit data embedded

The Prepare 8-bit Document command converts a 16-bit image into a 8-bit document with a smart object that contains the 16-bit image data. The path of the original file is added in brackets to the layer name of the smart object, which is required by the "Render 16-bit to Lightroom" command. This smart object can later be used to recreate the original 16-bit image. So make sure that you do not rename, delete, simplify or rasterize this smart object, otherwise rendering to 16-bit will not work. You can also save the prepared document in PSD or TIFF format and render it to 16-bit at a later time.

In previous ElementsXXL versions the 16-bit data was split into two layers. The new smart object method makes the document is easier to handle, preserves the meta data and allows editing the 16-bit image data anytime (without rendering back to 16-bit via the "Render 16-bit Document" command). The old "format" with the two Image Base layers is still supported, so you can still render such files.

After your prepared the document you can add smart filters, adjustment layers, other types of layers and smart objects to it. We recommend that you use the other menu items for adding smart filters and adjustment layers, because not all of them support 16-bit images, so they will not applied when rendering to 16-bit. The Add Smart Filter and Add Adjustment Layer menu items make sure that you only use supported ones.


Add Smart Filter

The Add Smart Filter command displays the Smart Filter panel that lists all usable smart filters. The "Display 16-bit filters only" check box is automativally activated to make sure that only smart filters that support images with 16-bit per channel are displayed. Please keep it activated to make sure that the smart filters are really applied when using the Render 16-bit Document command later. The left list box shows the filter groups, which you know as sub menus from the menu bar. The All group contains all available filters in the right list box whereas the other groups only display their own filters.

To apply a smart filter double click it in the right list box or select it and click the Add button. As a result the filter dialog appears. After adding smart filters you can immediately edit them again by clicking on the Edit tab button at the top. For more information see the Window Menu page.

When you are finished you can either close the panel with the cross icon at the top right or keep the panel open as you prefer.


Add 16-bit Layer

The Add 16-bit Layer command lets you choose another 16-bit document or open a 16-bit image file (e.g. TIFF, PSD, PNG or Camera Raw), which will be added as a smart object to the document.

If no other 16-bit document is open, a file dialog for opening a 16-bit image file appears. Otherwise a Select Source Document dialog shows up. If you choose the "Add Layer from File" list item on this dialog and click the OK button, a file dialog appears. Alternatively select one of the document names in the list box. If the Preview check box is active when you select another document, then the selected document is automatically displayed. This way you can be sure to select the right document in case you do not remember its file name or title.

Alternatively you can also use the File > Place or File > Place Linked menu items, which also embeds a 16-bit image file in a new smart object, provided this feature was not deactivated in the ElementsXXL Preferences.

The newly created smart object will have the 16-bit image data embedded. This way you can emulate 16-bit layers via smart objects and make sure that the final rendered image will contain true 16-bit data. You can now adjust the opacity or blend mode, add a layer mask, apply smart filters and do many other things with it. To edit the embedded 16-bit image data itself, double click on the thumbnail in the Layers panel. Just make sure that you do not simplify, rasterize or otherwise convert the image data of the smart object to 8-bit.


Add Adjustment Layer

The Add Adjustment Layer dialog lets you apply all adjustment layers that are supported for 16-bit rendering. Double click a list item or select one and click the Add button to apply it. As a result the dialog of the adjustment layer will appear. After you applied all adjustment layers click the OK button.

You can edit the adjustment layers any time by double clicking their thumbnail in the Layer panel. You can also edit their blend mode, opacity and layer mask there.

Color fill, gradient fill and pattern fill adjustment layers are supported, but only applied as rasterized image data and not rendered via filters to the 16-bit image. That is why they are not included in this dialog.


Add Dodge/Burn Layer

This menu item creates a special type of layer that is meant for dodge and burn operations with the dodge and burn tools. When choosing this menu item the dodge tool is automatically activated. You can switch to the burn tool on the Tool Options bar or by pressing the O key. Now brush over the image to selectively brighten or darken certain image areas.

You can also add a layer mask to this layer or change its blending mode to Soft Light or Hard Light for softer or hard effects. To vary the intensity of the effect either change the layer opacity or adjust the Exposure slider on the Tool Options bar.

When rendering the 16-bit document, the dodge/burn layer is blended with the 16-bit image. Although the layer itself is 8-bit, the blending makes sure that the result is still be 16-bit.


Add Tool Layer

The Add Tool Layer command simply adds an empty layer and displays some instructions. Alternatively you can also create such a layer by clicking on the New Layer icon of the Layers panel or use the Layer > New > Layer menu command.

You can use various tools on this empty layer. In some cases you have to activate the Sample All Layers check box on the Tool Options bar. Here is a list of tool that can be used:

It is a good idea to create more than one tool layer if you use multiple tools.

When the document is rendered to 16-bit, tool layers usually add 8-bit data to the 16-bit image. Only if the layer opacity or tool opacity is less than 100% and the blending mode is not Normal, then the 8-bit data is blended and produces true 16-bit image data. If the image data on a tool layer is fully opaque, it is added with 8-bit depth to the rendered 16-bit image.


Adding other layers

Apart from the options of the Render menu you can also add other types of layers to the document. For example, you can add a text layer with the text tool, a shape layer with the shape tool and add a layer with the smart brush tool.


Check Bit Depth

The Check Bit Depth command displays the number of tonal values and bits per channel that the currently selected layer contains. If you apply this command to an 16-bit image or a smart object, you can investigate if it contains true 16-bit data or not.

If the "Actual bits/channel" value is 12.0 or higher, you can be sure that the image is a true 16-bit image or that the selected smart object contains true 16-bit image data. If the displayed value is below 12.0, the image may have been upsampled from 8-bit and may not contain true 16-bit data. If the value is 8.0 or lower, you can be 100% sure that the image was upsampled. Please note that the maximum displayed values are 32768 and 15.0, because Photoshop and Photoshop Elements always cut off the 16th bit for performance reasons.

You can also make use of this function after rendering the 16-bit image. This way you can be sure, that the bit depth was not impaired by the rendering.


Render 16-bit Document

The Render 16-bit Document command produces a 16-bit image from the prepared 8-bit document. Supported adjustment layers and smart filters as well as smart objects with embedded 16-bit image data are rendered with 16-bit precision. Normal image layers may add 8-bit data if they are fully opaque and use a Normal blend mode. A text or shape layer means no problem, but opaque areas that were covered e.g. by the healing brush or clone stamp may loose their 16-bit depth. To avoid that you could set the layer opacity between 90 to 99% or choose another blend mode than Normal.

When triggering the Render 16-bit Document command ElementsXXL recreates the original 16-bit image from the bottom smart object and applies the other smart objects, smart filters, adjustment layer and image layers of the 8-bit document to it. A progress window is displayed in the top left corner, which indicates which layer is currently processed and the percentage of the completed work.

Rendering the 16-bit document can take several seconds depending on how big the image is and how many smart filters and layers have to be applied. The result is a new 16-bit document with one background layer. In the History panel you can see which filters and other operations were applied to it to reproduce the look of the 8-bit document.

If the look of the rendered 16-bit image differs from the look of the 8-bit document, please check if you did not apply an adjustment layer that is not supported or a smart filter that does not support 16-bit images. You may also get one ore more message if there is something wrong with the prepared 8-bit document.


Render 16-bit to Lighroom

The Render 16-bit to Lightroom command works similar to the Render 16-bit Document described above. Except that it does not display the newly rendered 16-bit document in Photoshop Elements, but insteads overwrites the original file provided by Lightroom. If this file cannot be found, a file dialog is displayed, which lets you select it or another file. Please only use this command if you previously opened a file from Lightroom in Photoshop Elements. If Lightroom is not running, this command does not work.

By activating the check boxes from the Lightroom Options command you can additionally make the Render 16-bit to Lightroom command automatically save the prepared document, close it and switch to Lightroom.


Lightroom Options

The Lightroom Options command lets the "Render 16-bit to Lightroom" command perform three additonal automatic tasks: saving the prepared document, closing the prepared document and switching to Lightroom. These options are displayed as check boxes in the Lightroom section of the ElementsXXL Preferences dialog.

The "Save Prepared Document" check box automatically saves the prepared document. If you did not save it before using the Render 16-bit to Lightroom command, the prepared document will be saved as a PSD file in the same folder as the original file with a "_render" suffix added to the file name. If you already saved it to to another folder, it will be updated there if necessary. In rare cases when a save folder cannot be determined, a file dialog will show up.

The "Close Prepared Document" check box closes the prepeared document. If you activated this check box without the "Save Prepared Document" check box, you will loose the prepared document if you did not manually save it.

The "Switch to Lightroom" check box automatically switches to the Lightroom window, where you can see the rendered result. This saves you a click on the task bar.

 

Split Layer

Supported by Photoshop Elements 11 and higher
Requirements: An image needs to be opened.
Added in ElementsXXL 3.0, extended in 4.0

The Split Layer sub menu offers menu items for splitting the current layer into various "channels". These "channels" will be added as new layers on top of the current layer and are linked to it with clipping masks. So adjusting these new layers will only affect the original layer. With the help of these new layers you can change the look of the original layer. After selecting a layer you can apply a filter or use a tool on it.

You can split a layer into RGB, CMY, CMYK, Lab, HSL, YCbCr, Luminosity & Color and two types of Frequency separation layers. The RGB, CMY and CMYK options are nice for colorizing effects. The Lab, YCbCr and Luminosity & Color options are useful for sharpening and noise reduction. The HSL layers are meant to selectively adjust the hue, saturation and lightness. Finally, the the Frequency separation layers are great for portrait retouching.

After you are finished with your adjustments, you can remove the split layers by selecting them as well as the original layer and choosing Layer > Merge Down.

 

Apply Image

Supported by Photoshop Elements 11 and higher
Requirements: An image needs to be opened. For blending two images you need to open two images with the same dimensions and mode.
Added in ElementsXXL 1.0, extended in 2.0, 4.0 and 5.0

The Apply Image menu item allows blending a channel with a layer or layer mask. It enables the user to easily create collage and layer effects as well as produce or modify masks. If a layer thumbnail is selected in the Layers panel, a channel (or the merged channels) is applied to the selected target layer with the help of certain blending and mask settings. If you select a layer mask in the Layers panel, the layer mask is modified. If the filter mask of a smart object is selected, then the filter mask will be changed.

If at least two image with the same dimensions and image mode are open in Photoshop Elements, the Select Source Document dialog will appear. Here you can choose another document as the source for the actual blending operation. If you keep "Current Document" selected here, you will only be able to use a layers from the active document. If the Preview check box is active and you select another document, then the selected document is automatically displayed. This way you can be sure to select the right document in case you do not remember its file name or title. After clicking OK the main Apply Image dialog appears.

To carry out the Apply Image feature choose a source layer from the Source combo box and a channel from the Layer combo box. Unfortunately the Selection combo box has no functionality (because it is a remnant of Photoshop's Apply Image feature), so please ignore it. An activated Invert check box inverts the selection.

You can then define the blend mode, opacity and mask that will be used when applying the source channel. When the Mask check box is activated, you can see more options for selecting a layer and channel, which will then be used as a mask. The appearing Channel combo box is another Photoshop remnant and can be ignored. Additionally the Preserve Transparency check box keeps the transparency of the target layer untouched.

 

Calculations

Supported by Photoshop Elements 11 and higher
Requirements: An image needs to be opened, but multiple images can be used.
Added in ElementsXXL 4.0

The Calculations menu item lets you create a new document, channel or selection by combining two channels and, if required, one mask. It is a convenient way to create a black & white variation of the current image, achieve a double-exposured black & white effect or produce a channel or selection for masking. Without it a lot of tedious operations would be necessary to achieve a similar result.

In the Source 1/2 combo boxes you can select one of the currently opened documents. If you select different documents, make sure they have the same size, otherwise the smaller image will be center aligned and does not fully cover the new document or channel. Under Layer you can select one of the layers of the document or the background. Under Channel you choose the red, green or blue channel or a "Gray" option, which is a combination of all RGB channels or the gray channel of grayscaled images. If you select a layer, you also get a Transparency option, which is the alpha channel of the layer. If the layer has a layer mask, there is a "Layer Mask" option. Finally, if the layer is a smart object with a smart filter applied to it, you can also choose its filter mask. The Invert check box inverts the tones of the channel and produces a negative version of it.

The channels selected under Source 1 and 2 will be blended with the blend mode of the Blending combo box and the Opacity value below it. If you activate the Mask check box, you can additionally choose a third channel, which will be used as a mask when blending the two channels. The Invert check box creates a negative version of the mask.

The Result combo box determines if the combined channels will be placed in a new document, added as a new channel to the current document or made available as a selection in the current document. If you decide to create a new channel, you can use the Select > Load Selection menu item to produce a selection of it or you can use ElementsXXL's Channels panel to work with it.

 

Mode > 16 Bits/Channel

Supported by Photoshop Elements 11 and higher
Requirements: An image with 8-bits per channel.
Added in ElementsXXL 1.0, improved in 2.0 and 3.0

Normally Photoshop Elements only supports converting images from 16-bit to 8-bit per channel. ElementsXXL adds this feature to the Mode sub menu to also let you convert 8-bit to 16-bit images. Please note that Photoshop Elements does not support layers for 16-bit images, so all layers will be flattened when doing this conversion. The selection is retained by the conversion.

After triggering this command you will see a dialog with three options. The Open New Document check box opens a new window when converting the image to 16 bits per channel and retains the original 8-bit document with all layers and history states. Otherwise you lose them.

If an image does not use the sRGB or Adobe RGB color profile, you have to choose if you rather want to preserve the meta data or the color profile of the image during the 16-bit conversion. Then the Preserve Meta Data and Preserve Color Profile radio buttons will be enabled. If both options are disabled, both the meta data and color profile will be preserved.

 

Channels

Supported by Photoshop Elements 11 and higher
Requirements: The image has to be in RGB mode.
Added in ElementsXXL 1.0

Each image consists of three color channels: Red, Green and Blue. The Channels sub menu lets you view and edit the different color channels according to your preferences. Once having selected a certain channel, you can apply all tools and filters to it.

The RGB menu item, which is the default setting, selects and displays all three color channels. The Red, Green, Blue, Red + Green, Red + Blue and Green + Blue menu items let you view and select the different color channels and channel combinations. If you want to edit all three channels again, please choose the RGB item. The Show All menu item shows all channels, even if only one or two of them are selected for editing.

A more advanced alternative to the Channels sub menu is the Channels panel, which can be displayed from the Window > Channels menu.

 

Convert Color Profile > Convert To Profile

Supported by Photoshop Elements 11 and higher
Requirements: An image has to be opened.
Added in ElementsXXL 3.0

The Convert To Profile function lets you convert the image from the current color profile (shown under Source Space) to another profile, which is selectable under "Destination Space". As a result the image will use the new color profile while still looking (more or less) the same. This feature is useful if you want to display or print an image on a device that uses a different color space.

This conversion flattens all layers and makes previous history states inaccessible. To avoid that you have to apply this operation right after opening an image, which is highly recommended. Alternatively you can activate the "Open New Document" check box. Then the image will be duplicated and the profile conversion will be performed on the new document.

 

Convert Color Profile > Assign Profile

Supported by Photoshop Elements 11 and higher
Requirements: An image has to be opened.
Added in ElementsXXL 3.0, accelerated in ElementsXXL 5.0

The Assign Profile function assigns a new color profile as selected under "Destination Space" to the current images. While the "Convert To Profile" command changes the pixel values to keep the look of the image (more or less) the same, the Assign Profile command keeps the pixel values unchanged, which results in a changed image look because of the new color profile. So Assign Profile has two main areas of application: You can use it to add a color profile to an image that is missing one or you can abuse it for color effects.

This command flattens all layers and makes previous history states inaccessible. To avoid that you have to apply this operation right after opening an image, which is highly recommended. Alternatively you can activate the "Open New Document" check box. Then the image will be duplicated and the profile assignment will be performed on the new document.

 

Add Color Lookup Pattern

Supported by Photoshop Elements 11 and higher
Requirements: An RGB image has to be opened
Added in ElementsXXL 4.0

This menu item expands the image canvas and adds a lookup pattern at the top left corner of the image. No image pixels are overwritten this way. This lookup pattern is only necessary if you want to use a 16-bit image (e.g. for more precise color values) or want to capture the effect of a filter. A lookup pattern is not needed if you use a 8-bit image and only add adjustment layers for producing an effect.

You have to choose a grid point value and a lookup format with the appropriate controls. The higher the grid point value, the more colors will be sampled, which results in a better quality but the larger the lookup file will be. We recommend values between 16 (4096 colors, 50-100K file size) and 32 (32768 colors, 400-800K file size). The 3DL format produces file sizes that are half as large as CUBE or CSP.

After you added the lookup pattern by clicking the OK button, you can apply filters to the image thus producing a desirable effect. This effect can be saved as a lookup file with the File > Save > Color Lookup Table command and applied to any image with the Color Lookup filter or adjustment layer.

Please note: The grid point value and format have to be the same on the Add Color Lookup Pattern dialog and the Color Lookup Table dialog, otherwise the produced lookup file will contain nonsense values that do not reproduce the effect.