Layer Menu

 

ElementsXXL adds several new sub menus and dozens of menu items to the Layer Menu of Photoshop Elements.

 

New

Supported by Photoshop Elements 13 and higher
Requirements: A 16-bit/channel image needs to be open
Added in ElementsXXL 4.0

This commands converts the background layer of an 16-bit image into a regular layer that supports transparency. You can do the same by clicking on the lock symbol in the Layer panel or by double clicking the image thumbnail in the Layers panel while holding down the Alt key. As Photoshop Elements 13 (and higher) only supports one layer for 16-bit images, you can only decide to have a background layer or regular layer. To convert it back to the background layer and remove the transparency use the Layer > Flatten Image menu item.

 

New > Group

Supported by Photoshop Elements 11 - 14, already included in Photoshop Elements 15 and higher
Requirements: A 8-bit/channel image needs to be open
Added in ElementsXXL 3.0

This commands adds an empty layer group. You can add layers to this group by dragging one or more layers and dropping them onto this group in the to the Layers panel. See the Group Layers command below for more information.

 

New > Group From Layers

Supported by Photoshop Elements 11 - 14, already included in Photoshop Elements 15 and higher
Requirements: A 8-bit/channel image needs to be open
Added in ElementsXXL 3.0

This commands encloses the selected layers in a new laye group. So please select the layer or layers that you want to be included in a layer group before you executes this command. This command works just like the Group Layers command below.

 

Delete > Hidden Layers

Supported by Photoshop Elements 11 and higher
Requirements: A 8-bit/channel image needs to be open
Added in ElementsXXL 3.0

The Delete Hidden Layers menu item deletes all layers that are hidden but not protected. Layers with a 0% opacity will not be deleted.

 

Delete > Empty Layers

Supported by Photoshop Elements 11 and higher
Requirements: A 8-bit/channel image needs to be open
Added in ElementsXXL 3.0

The Delete Empty Layers command deletes all layers that have no visible pixels and are not protected. This also includes text layers without text.

 

Quick Export as ...

Supported by Photoshop Elements 11 and higher
Requirements: An image has to be opened.
Added in ElementsXXL 5.0

The Quick Export as PNG/JPEG/GIF command saves the currently selected layers according to the settings on the Export sheet of the ElementsXXL Preferences. If you hold down the Ctrl key and click on this menu item, the ElementsXXL Preferences dialog appears with the Export sheet selected.

 

Smart Filter

Supported by Photoshop Elements 11 and higher
Requirements: A smart object with an applied smart filter must be selected in the Layers panel
Added in ElementsXXL 1.0, improved in 2.0, 3.0, 4.0 and 5.0

Smart filters allow readjusting their filter settings after they have been applied, so they make non-destructive image editing possible. On the other hand they can only be applied to smart objects. Read more about smart objects below.

The Smart Filter sub menu lets you edit the smart filters of a smart object. It is only accessible if at least one smart filter is applied to a smart object. In Photoshop Elements 6 and 7 it is already accessible if a smart object without a smart filter is selected in order to avoid a delayed display of this sub menu. To apply a smart filter to a smart object use the Filter menu.


Menu Items at the Top

The names of the smart filters that are applied to the current smart object are displayed at the top of this menu. By clicking the name of one of the filters, its dialog options are displayed. So this is a fast way to change the settings of a smart filter.


Edit Smart Filters

The Smart Filters panel allows you to change the settings, blend mode and opacity of each smart filter that is applied to a smart object. Additionally you can enable, disable or delete each smart filter. This panel can also be displayed by clicking the smart object icon or smart filter symbol on the Layers panel. For more information see the Windows Menu page.


Enable/Disable Smart Filters

This item disables or enables all smart filters of a smart object.


Clear Smart Filters

This item deletes all smart filters of a smart object.


Select & Hide Filter Mask

This item selects the filter mask. The filter mask is similar to a layer mask, but it only masks the effects of the smart filters. The filter mask is automatically selected after adding a smart filter via the Filter > Add Smart Filter menu item. Otherwise you can use this menu command to select it again or alternatively hold down the alt key and click on the smart object icon of the Layers panel. If the filter mask was made visible with the Show Filter Mask command, this command also hides it again. The filter mask can be modified with a tool or a filter.


Deselect Filter Mask

This item simply deselects the filter mask of a smart object. That way you cannot apply tools to it anymore and you can apply smart filters that do not support grayscaled images from the sub menus of the Filter menu again.


Show Filter Mask

This item shows the filter mask as a grayscale image while hiding the actual image. This is quite useful if you want to make adjustments that are not so visble with the normal image view. To switch back to normal view please use the "Select/Hide Filter Mask" command.


Invert Filter Mask

This commands inverts the filter mask. So all areas that are affected by the smart filters will be unaffected and vise versa. If you did not edit the filter mask, this command hides the effect of the smart filters. Apply it again to reverse its effect.


Properties

This commands lets you adjust the density and feathering of the filter mask. A decreased density makes transparent mask areas opaque again, which means that the smartfilter effect returns gradually. Feathering softens the transition between the transparent and opaque mask areas. When using this command the Properties panel will be displayed. See the Window > Properties command for more information.


Disable/Enable Filter Mask

This item disables or enables the filter mask. If the filter mask is disabled, the effects of the smart filters are not masked anymore. If you did not modify the filter mask, these menu commands will make no difference.


Add Filter Mask

This item creates a new filter mask from the current selection. The old filter mask is lost. To create a selection from the filter mask see the Select > Select From > Filter Mask menu command.


Clear Filter Mask

This item erases the content of the filter mask. The effects of the smart filter will then be applied to the whole image again.

 

New Adjustment Layer

Supported by Photoshop Elements 11 and higher
Requirements: An 8-bit/channel image needs to be opened.
Added in ElementsXXL 1.0, extended in 4.0

ElementsXXL adds up to 9 additional adjustment layers to the New Adjustment Layer sub menu: Curves, Exposure, Vibrance, Black & White, Color Balance, Channel Mixer, Selective Color, Color Lookup and Replace Color. The dialog is identical to the filter version of these adjustment layers, so please read the Enhance Menu page for more information.

Filters are only applied to one layer whereas adjustment layers affect all layers underneath them. Except, if they have a clipping mask activated, they affect only the layer right below them. Similar to smart filters the settings of adjustment layers can be readjusted. To do that please double click the thumbnail of the adjustment layer in the Layers panel.

 

Type

Supported by Photoshop Elements 11 and higher
Requirements: A text layer has to be selected in the Layers panel.
Added in ElementsXXL 1.0, extended in 3.0 and 5.0

ElementsXXL adds several new features to the Type sub menu for influencing text layers.


Create Work Path

This command creates a path from the current text layer. See the Paths panel for more information on paths.


Convert to Shape

This command converts a text layer to a shape layer. Text that was converted to a shape offers some creative freedom that is not possible with text layers. On the image below the Shape Selection tool was used to resize, rotate and reposition each letter individually.



On the other hand once you converted a text layer to a shape, you cannot change the text contents anymore. To have a backup better duplicate the text layer before converting it to a shape.


Anti-Alias Off / Crisp / Sharp / Strong / Smooth / Windows LCD / Windows

ElementsXXL adds five new text anti-aliasing methods. Anti-Alias Crisp replaces the original Anti-Alias On menu item, so it produces the same effect. The Sharp, Strong and Smooth methods produce a different degree of anti-aliasing, which makes the text look either sharper or smoother than the default Crisp setting. The Windows LCD and Windows options use the font anti-aliasing methods of the Windows operating system. The Windows LCD option only uses grayscales for anti-aliasing whereas the Windows option may also use other colors.


Convert to Paragraph/Point Text

By default a text layer is set to point text, which means that the text area will expand when you enter more text. If you convert it to paragraph text, the text area will stay constant and not expand or shrink when changing the text. This is useful if you want to constrain a text layer to a certain area in an image.


Tracking

The Tracking dialog lets you adjust the distance between each letter of a text. Set the tracking to zero to have the default distance.

Font Preview Size

The Font Preview Size sub menu lets you decide between five sizes from Small to Huge. There is also a None option does not display any font preview in the Tool Options window at all and only shows the font names.

Here you can see the Tool Options panel with a large font preview on the left and a small font preview on the right:

      

 

 

Layer Mask

Supported by Photoshop Elements 11 and higher
Requirements: A non-background layer has to be selected.
Added in ElementsXXL 1.0, extended in 3.0

Each layer can have a layer mask. A layer mask defines which areas of a layer are visible (opaque), partially visible (transparent) or invisible (fully transparent). Layer masks are basically grayscaled images and can be edited like them. White areas in the layer mask indicate full opacity whereas black area represent fully transparent areas. Gray mask areas mean partial transparency. Dark gray mask areas are more transparent that bright gray ones.

Layer masks are displayed as black & white thumbnails at the right hand side of the image thumbnail in the Layers panel. You can click their thumbnail to select them (which displays a colored frame around them) and start editing them instead of the layer image. You can modify a layer mask with all available tools and filters. To edit the layer image again click the image thumbnail.


From Transparency

The From Transparency command uses the transparency information of a layer (the so-called alpha channel) when creating a layer mask. The transparent layer areas will be black in the layer mask.


Properties

This command displays the Properties panel for adjusting the density and feathering of the layer mask. The density slider controls the transparency of the areas that are not covered by the layer mask. The feather slider softens the edges of the layer mask. For more information see Window > Properties.

 

Vector Mask

Supported by Photoshop Elements 11 and higher
Requirements: An image has to be opened
Added in ElementsXXL 1.0, improved in 2.0, 3.0
, 4.0 and 5.0

A vector mask is similar to a layer mask, but consists of vector graphics instead of normal image data. It also controls the transparency of a layer. A vector mask is resolution independent and can easily be scaled and transformed with the Shape Selection tool without getting pixelated. You can only edit it with the pen, path and shape tools and the commands from the Rotate and Transform sub menus of the Image menu. You can edit shapes with these menu commands as well, because shapes are actually solid color adjustment layers with a vector mask.

Vector masks are displayed as thumbnails at the right hand side of the image thumbnail in the Layers panel.


Reveal All

The Reveal All menu item creates an empty vector mask that makes the whole layer opaque. To reveal only a part of the layer go to the Edit > Tools > Text on Pen Tool and draw on the image.


Hide All

The Hide All menu item creates an empty vector mask that makes the layer fully transparent. To reveal a part of the layer again go to the Edit > Tools > Text on Path Tool and draw on the image.


Current Path

This item applies the currently selected path as a vector mask. For information about creating a path see Edit > Tools > Text on Path Tool.


From Selection

Uses a selection to create the vector mask. The selected areas will also be visible and opaque whereas the other areas will be fully transparent.


From Shape

After creating a shape with the shape tool you can use this feature to create the vector mask from the shape. The shape area will be visible and opaque whereas the other areas will be fully transparent in the vector mask. The shape layer is removed when adding it as a vector mask to the layer underneath.


Properties

This command displays the Properties panel for adjusting the density and feathering of vector masks as well as shapes. The density slider controls the transparency of the areas that are not covered by the vector mask or shape. The feather slider softens the edges of the vector mask or shape. For more information see Window > Properties.


Delete

Removes the vector mask.


Disable/Enable

Activates or deactivates the vector mask without removing it. You can do the same by holding down the Shift key and clicking on the vector mask thumbnail in the Layers panel.


Link/Unlink

Links or unlinks the vector mask from the layer image. When the vector mask is unlinked, the layer image can be repositioned independently of the vector mask with the move tool. The vector mask can be repositioned independently at any time with the shape selection tool, so unlinking is not necesarry for that.

 

Smart Object

Supported by Photoshop Elements 11 and higher (Linked smart objects require Photoshop Elements 13 and higher)
Requirements: An image needs to be opened.
Added in ElementsXXL 1.0, improved in 2.0, 3.0 and 4.0

A smart object is a special kind of layer that contains a document or file that is kept untouched. Thus a smart object can contain multiple layers and other information. All operations are applied to a flattened copy of the embedded document. Smart objects guarantee a non-destructive editing of image data as well as the use of smart filters.

Besides the basic smart objects ElementsXXL also provides linked smart objects in Photoshop Elements 13 and higher. Linked smart objects are linked to a source file, which was used for creating them. They automatically updated when their source file changes - provided that the documents with the linked smart objects are open in Photoshop Elements when the source file is updated. Otherwise the smart objects have to be updated manually after opening their file again.

In Photoshop Elements 13 the commands "Reveal in Explorer", "Update Modified Content" and "Embed Linked" are not available, because ElementsXXL cannot detect a linked smart object and cannot read the path of the linked file. So basically linked smart objects do not offer much more functionality than normal smart objects in Photoshop Elements 13.



Convert to Smart Object

This feature converts all selected layers into a single non-linked smart object. To embed an image file you can also use the Open > As Smart Object or the Place menu item from the File menu. To create a linked smart object please use the File > Place Linked menu item or apply the "Relink to File" menu item (see below) to a normal non-linked smart object.


New Smart Object via Copy

The "New Smart Object via Copy" menu item simply duplicates a smart object. You can also use the normal Duplicate Layer command instead.


Reveal in Explorer
(Photoshop Elements 14 and higher)

This command shows the source file of a linked smart object in the Windows Explorer.


Update Modified Contents
(Photoshop Elements 14 and higher)

If the source file of a linked smart object was changed while the document with the linked smart object was closed, you will see an yellow exclamation mark in the smart object thumbnail in the Layers panel. To update the linked smart object with the contents of the source file, please choose this menu item. If you do not want that and want to keep the smart object seperated from the source file, you can choose the Embed Linked menu item (see below) to convert it into a normal non-linked smart object.


Relink To File
(Photoshop Elements 13 and higher)

If the source file of a linked smart object was deleted, renamed or moved to another location, a red question mark appears in the smart object thumbnail in the Layers panel. In such a case you will also get a dialog about "Cannot locate linked assets" when opening the document with the linked smart objects. Unfortuntelly this dialog is broken and does not let you relink to the source file. Instead please use this "Relink To File" menu item. In the appearing dialog, please choose the original source file or a new file. If you use this menu item with a normal smart object, it will be replaced with a linked one.



Edit Contents

The Edit Contents feature can also be triggered by double clicking the thumbnail of a smart object in the Layers panel.

If a camera raw file is embedded in the smart object, the Edit Contents command lets you readjust the Camera Raw settings of the raw file. When the Adobe Camera Raw dialog shows up, edit the settings and click the Open Image button to apply the changes.

If the smart object has no raw file embedded, the Edit Contents command opens the document that is embedded in the smart object for editing. In the case of a linked smart object its source file is opened instead. To commit the changes to the smart object in the original document choose File > Save or press Ctrl + S. If the smart object has smart filters applied to it, these filters are then rendered again.

If the smart object was created in Photoshop, the smart object may have a .psb document embedded. As Photoshop Elements does not recognize this file extension, please do the following to make the smart object editable:

1. Use the Export Contents command (see below) to save the embedded .psb file,
2. Rename the file extension of this file from .psb to .psd.
3. Use the Replace Contents command (see below) to embed the .psd file into the smart object.
4. Try the Edit Contents command again.


Edit in Camera Raw

This menu command lets you edit the embedded document of a non-linked smart object or the linked file of a linked smart object with the Camera Raw dialog even if it is not a raw file.

However, this feature changes the smart object, which has the following consequences:

1. A linked smart object is converted into a normal smart object.
2. All layers of the embedded document of the smart object will be flattened.
3. When saving the document that contains the smart object, the file size may be bigger than before. It may also be smaller if the smart object contained layers which were flattened.
4. The Edit Contents command will now work just like the Edit in Camera Raw command and double clicking the smart object thumbnail in the Layers panel will also trigger editing in Camera Raw.


Export Contents

If you want to save the contents of a non-linked smart object as a file, you can use this command. If the smart object was created in Photoshop, it is likely that it will be saved as a .psb file. Photoshop Elements does not support this file extension, so please rename its file extension to .psd to be able to open it again.


Replace Contents

Replace Contents enables you to replace the document that is embedded in the smart object while keeping the settings of the smart object including its smart filter untouched. Make sure that the new document has the same image size as the current one, otherwise it will be resized.


Unwrap Contents

The Unwrap Contents features places the contents of a smart object as one or more layers in the current document. In the case of a linked smart object the embedded image is added as one new layer, even if the linked document contains multiple layers. If you edited the smart object with Camera Raw or added some smart filters, these effects will not be visible on the new layer(s). If you want them, better duplicate the smart object and simplify it. However, the changes that you applied with the Edit Contents command in a second document window will still be visible on the new unwrapped layer(s).


Embed Linked
(Photoshop Elements 14 and higher)

This menu item simply turns a linked smart object into a normal non-linked smart object. This way it cannot be updated automatically anymore when the source file was changed.


Convert To Linked
(Photoshop Elements 13 and higher)

This command converts a normal smart object into a linked smart object by saving the embedded content of the smart object to a file and linking to this file. A file dialog will appear for choosing the location and name for the new file. If you instead want to convert the smart object into a a linked smart object by using an existing file, please use the Relink To File menu item (see above).

 

Rasterize

Supported by Photoshop Elements 11 and higher
Requirements: One or more layers have to be selected.
Added in ElementsXXL 3.0, extended in ElementsXXL 5.0

The Rasterize commands are similar to the Simplify Layer command with the difference that they preserve the layer mask and layer styles. They convert vector data (e.g. vector masks, text layers, shape layer), fill layers and smart objects to plain pixels. To convert layer styles to pixel informaton you have to use the Simplify Layer command.


Type

The Rasterize > Type command turns a type layer into a pixel layer without converting the vector mask of the type layer to a layer mask as the Rasterize > Layer command would do.


Shape

The Shape command rasterizes only shape layers and not other types of layers.


Fill Content

This command is meant for shape layers. It turns a shape layer into an image layer with a vector mask. The color of the "shape" is now only editable by changing the color of the new image layer. This command also works on fill layers, but it has the same effect as the Layer command.


Vector Mask

Transforms the vector mask into a normal layer mask, which is more flexible for certain tasks, but is resolution dependent. If you apply it to a shape layer, you get a fill layer with a layer mask.


Smart Object

This command rasterizes only smart objects and not other types of layers.


Layer Styles

The Layer Styles command rasterizes layer styles.


Layer

This commands rasterizes the selected layer(s). This means that smart objects, text layers, fill layers and shape layers will be converted into image layers. Additionally vector masks will be transformed into normal layer masks.


All Layers

It works just like the Layer command, but rasterizes not only the selected layers but all available layers.

 

Group Layers

Supported by Photoshop Elements 11 - 14, already included in Photoshop Elements 15 and higher
Requirements: One or more layers have to be selected.
Added in ElementsXXL 1.0

The Group Layers command embeds the selected layer(s) into a layer group, which is displayed with a folder symbol in the Layers panel. Layer groups let you organize layers better and give you a better overview if you use a lot of layers. Another advantage of layer groups is that you can apply the same blend mode and opacity to all layers in a group. Even more, you can add a group mask in addition to the layer masks that each of the included layers may already have.

You can also click on the layer group icon on the Layers panel to group (and ungroup again) the selected layers.

 

Left: Multiple layers were selected for inclusion in a layer group. Right: The resulting layer group.


Unfortunately once the layers are included in a layer group they cannot be edited anymore (except for Photoshop Elements 15 and higher), unless you ungroup them again. In Photoshop Elements 8-14 ElementsXXL lets you store the properties of the last layer group (including its mask) when ungrouping it, to avoid losing them. See the Ungroup Layers section below for more information.

If the properties of an old layer group were saved, you will see the following message when trying to create a new layer group in Photoshop Elements 8-14:

If you want to restore the properties of the old layer group, click "Yes". If you want to create a totally new layer group, click "No". In this case the properties of the old layer group will be lost. If you want to avoid that, click Cancel and recreate the old layer group before creating a second, totally new layer group.

A new layer group is set to "Pass Through" blend mode by default, which means that it affects all layers below it. If you do not want that, simply change the blend mode of the layer group to "Normal". Actually, doing this (including a layer in the layer group and setting the blend mode of the layer group "Normal") is also a workaround for the limitation in Photoshop Elements of not being able to use clipping masks together with layer groups.

 

Ungroup Layers

Supported by Photoshop Elements 11 - 14, already included in Photoshop Elements 15 and higher
Requirements: A layer group has to be selected.
Added in ElementsXXL 1.0

If you want to edit the layers included in a layer group, you have to ungroup them with this command. You can also use the layer group icon on the Layers panel.

Ungrouping a layer group would normally mean that its properties are lost. If the layer group has no mask, then its name, blend mode and opacity are stored automatically - provided you edited one of them. In Photoshop Elements 8-14 when creating a new layer group, you will be asked if you want to recreate the properties of the old layer group (as shown above).

If the group has a mask when ungrouping it, the above message will appear. Click Yes to store the mask and other properties of the layer group. Doing so will give you the option of restoring them again with the Group Layers menu command (see above). The main reason for this message is that the group mask is stored as a channel, which increases the document size. So you have the choice not to store it if you do not want to recreate a layer group.

 

Hide/Show Layers

Supported by Photoshop Elements 11 - 14, already included in Photoshop Elements 15 and higher
Requirements: One or more layers have to be selected.
Added in ElementsXXL 1.0

Normally you can only make single layers invisible or visible by clicking the eye symbol in the Layers panel. With the help of this menu item you can hide or show multiple layers that are selected in the Layers panel.

 

Combine Shapes

Supported by Photoshop Elements 13 and higher
Requirements: At least two shape layers have to be selected in the Layers panel
Added in ElementsXXL 3.0

The Combine Shapes submenu offers four menu items for uniting or subtracting two or more shape layers, which results in a single shape layer. All shapes can still be individually selected and edited with the shape selection tool. They only happen to be located on the same layer after using of these four commands.

The Unite Shapes command combines two or more shape layers into a single shape layer. The shapes themselves are left untouched.

The Subtract Font Shapes command subtracts the top shape layer(s) from the bottom shape layer. This means that the areas of the bottom shape that are covered by the top shape(s) become transparent. If all shape layers are identical, the result is a totally transparent shape layer.

The Unite Shapes At Overlap command keeps only the areas covered by all shape layers opaque in the resulting shape layer. So only the intersection of all shapes becomes opaque. The non-overlapping areas of the shapes get transparent.

The Subtract Shapes At Overlap command makes the area that is covered by all shapes transparent in the resulting shape layer. The non-overlapping areas of the shapes are still opaque. The intersecion of the shapes gets transparent.

 

Align (Layers to Selection)

Supported by Photoshop Elements 11 and higher
Requirements: Either a selection has to be available or at least two layers have to be selected in the Layers panel

Added in ElementsXXL 1.0

If a selection is present, the Align commands align a certain border of the selected layer(s) to the selection. If no selection is available, they align the bottom layer(s) to a certain border of the top layer. The items of this sub menu determine the border to which the layers are aligned.

You can find the same commands as icons on the tool options bar of the move tool.

 

Distribute

Supported by Photoshop Elements 11 and higher
Requirements: At least three layers have to be selected in the Layers panel

Added in ElementsXXL 1.0

The Distribute commands distribute three or more layers equally by making sure that the same amount of space is between each layer. You can select in which direction the equal distribution is performed by choosing one of the items of this sub menu.

This feature works best with transparent image layers, which do not contain image data across the full width or height of the document. Otherwise there is no room for distributing the different layers.

You can find the same commands as icons on the tool options bar of the move tool.

 

Lock Layers

Supported by Photoshop Elements 11 and higher
Requirements: At least one layer has to be selected in the Layers panel
Added in ElementsXXL 3.0

The Lock Layers command displays a dialog for locking certain aspects of the selected layer(s). Locked means that these aspects cannot be edited. You can lock the transparency, position and image (pixel values) of a layer or all of them by using the All check box.

The lock icon on the Layers panel has the same effect as the All check box. The checkerboard lock icon on the Layers panel resembles the Transparency check box of the Lock Layers dialog. However, the Position and Image check boxes do not have icon on the Layers panel, so you can only trigger them here.

 

Link / Unlink Layers

Supported by Photoshop Elements 11 and higher
Requirements: One or more layers have to be selected in the Layers panel
Added in ElementsXXL 3.0

The Link Layers command links the currently selected layers. This means that certain operations, e.g. repositioning with the move tool, is automatically performed on all linked layers, even if only one of the linked layers is selected. To unlink the layers again please select them an use the Unlink Layers command. If you linked multiple layers and only want to unlink one of these layers, only select this layer when using the Unlink Layers command.

You can perform the same operations by clicking one of the chain symbols in the Layers panel.

 

Select Linked Layers

Supported by Photoshop Elements 11 and higher
Requirements: At least one layer has to be selected in the Layers panel
Added in ElementsXXL 3.0

If only one linked layer is selected, you can use this command to automatically select all linked layers in the Layers panel. This is especially convenient if the linked layers are located apart from each other, which would otherwise require scrolling and multiple clicks in the Layers panel.

 

Stamp Down / Stamp Layers / Stamp Group

Supported by Photoshop Elements 11 and higher
Requirements: An image has to be opened
Added in ElementsXXL 5.0

If one layer is selected, this menu item is called "Stamp Down" and adds the pixels of the current layer to the layer below. Unlike the Merge Down command the current layer is not removed.

If more than one layer is selected, the menu item is renamed "Stamp Layers" and creates a merged copy of the selected layers as a new pixel layer. If a layer group is selected, the menu item is called "Stamp Group" and lets you create a merged copy of the layer group as a new pixel layer.

 

Stamp Visible

Supported by Photoshop Elements 11 and higher
Requirements: An image has to be opened
Added in ElementsXXL 1.0

The Stamp Visible command adds a flattened version of all layers as a new layer on top of all layers. This is very useful if you want to apply a filter to the whole image while keeping all layers. It is an alternative to the Flatten Image command, which removes all layers.

 

Merge Group

Supported by Photoshop Elements 11 and higher
Requirements: A layer group has to be selected
Added in ElementsXXL 5.0

The Merge Down / Merge Layers menu item is provided by Photoshop Elements itself. If a layer group is selected, ElementsXXL renames this menu item to "Merge Group" and lets you merge a layer group into a normal pixel layer with it.

 

Matting

Supported by Photoshop Elements 11 and higher
Requirements: A layer with a layer mask
Added in ElementsXXL 3.0

The Matting submenu contains four menu items for dealing with the border pixels of a layer mask depending on which matting technique was used when taking a photo. So before you use one of these commands you must cut out an object in the image with the help of a layer mask. You can also use a selection and then turn it into a layers mask. The cut-out should be rather precise for these commands to work effectively.

The Color Decontaminate command removes colored pixel at the edges of the layer mask. It only works in Photoshop Elements 11 and higher.

The Defringe command removes halos at the edges of the layer mask. You can enter the halo with in the appearing dialog.

The Remove Black Matte command brightens dark pixels at the layer mask edges. This is useful for objects taken in front of a dark background.

The Remove White Matte command darkens white pixels at the layer mask edges. This is useful for objects taken in front of a bright background.