Compatibility

 

FilterHub works under Windows 8, 7, Vista, XP (32-bit & 64-bit) as well as MacOS X (10.4.11 and higher).


Under Windows it requires one of the following applications to be installed:


Under MacOS X it requires one of the following applications to be installed:


The FilterHub UI is only available in English and German, but it supports all localized versions of Photoshop.


Partially Supported under Windows:
Photoshop 5, 5.5, 6 (the old pre-CS versions) and Photoshop Elements 1. Only the built-in filters (and no plugins) are available when running FilterHub in them.

The FilterHub automation plugin for Windows requires the Adobe Flash Player with a certain minimum version number. If it is not installed, FilterHub displays a message and connects you to the Flash Player web page, where you can install it. The FilterHub 32-bit plugin requires at least Flash Player 9.0.28, whereas the FilterHub 64-bit plugin requires at least Flash Player Square 10.2 (but Flash Player 11 would be better).