Batch Processing

 

Batch Processing in Photoshop

Photoshop offers a Batch feature on its File > Automate menu. This feature lets you batch process a series of images with the help of a Photoshop action. So if you want to batch process images in Photoshop you only need to record an action that contains HyperTyle.




Recording an action with HyperTyle:

1. Open an image in Photoshop.

2. Switch to the Actions panel at the right and create a new action by using the New Action button or the pop-up panel menu.

3. Choose HyperTyle from the Filter menu.

4. Now adjust the effect settings in HyperTyle as you want them recorded in the action.

5. Press OK on the HyperTyle dialog.

6. Press the Stop button on the Action panel. Now you have your HyperTyle action that you can use with File > Automate > Batch.


Batch processing a series of images with HyperTyle:

1. Open one of the images from the image series.

2. Select File > Automate > Batch.

3. In the Batch dialog make sure that your HyperTyle action is selected.

4. Set the other batch options and click OK to run it.


You can record a new action for each task that requires a different HyperTyle effect. On the other hand if you do not want to create a collection of different actions, you can also change the HyperTyle settings of the action. To do that click on the HyperTyle item in the Actions panel, change the settings in the HyperTyle dialog and press OK. If you want to apply individual HyperTyle settings to each image during batch processing, please activate the small icon left of the HyperTyle entry in the Action panel. This makes the HyperTyle dialog appear for each image, so that you can adjust the settings for each image.

 

Batch Processing in Paint Shop Pro

Paint Shop Pro (Version 8 and higher) offers a Process feature on the File > Batch menu for batch processing a series of images with the help of a PSP script. Recording such a script is quite easy.


Recording a PSP script with HyperTyle:

1. Open an image in PSP.

2. Select File > Script > Start Recording.

3. Choose HyperTyle from the Effects > Plugins menu.

4. Now adjust the effect settings in HyperTyle as you want them recorded in the script.

5. Press OK on the HyperTyle dialog.

6. Select File > Script > Stop Recording and save the script. Now you have a HyperTyle script that you can use with File > Batch > Process.


Batch processing a series of images with HyperTyle:

1. Open one of the images from the image series.

2. Select File > Batch > Process or File > Batch Process.

3. In the Batch Process dialog choose your HyperTyle script from the Script frame.

4. Set the other batch options and click on the Start button to run it.

You need to record a new script for every HyperTyle effect that you want to apply during batch processing. You can create a collection of scripts with various HyperTyle effects and use these scripts as you need. If you want to apply individual HyperTyle settings to each image during batch processing, please deactivate the "Silent mode" check box on the Batch Process dialog. This makes the HyperTyle dialog appear for each image.

 

Batch Processing in Other Applications

There are some other applications that support batch processing with the help of plugins, e.g. Fireworks, Debabelizer and Photo-Paint. Basically batch processing in other applications works the same as in Photoshop and Paint Shop Pro.