Camera Raw Filter / Smart Object

In addition to providing enhanced support for raw files, MetaRaw includes other features, which allows you to apply the effects of Adobe Camera Raw to an already opened image as well as create a smart object that can be edited with Camera Raw. The file format of the opened image does not matter. The mode of the image has to be RGB, Grayscale, CMYK or Lab with 8-bit or 16-bit per channel. If it is not the case, MetaRaw asks for conversion into RGB image mode.


Camera Raw Filter

MetaRaw's Camera Raw Filter feature allows you to apply the effects of Adobe Camera Raw to an already opened image. You can run it in Photoshop from the File > Automate > Camera Raw Filter menu item and in Photoshop Elements from the File > Automation Tools > Camera Raw Filter menu item. Then the Adobe Camera Raw dialog shows up and you can choose your effect settings. Finally click the OK button (or Open Image button) to apply the effect to the image.

This feature supports layers, selections and transparent areas (alpha channel) of layers. It does not touch layer masks, vector masks and layer effects. However, if you apply it to a smart object, you are asked whether you want to rasterize it. This means that the smart object will be transformed into a normal layer. So best apply Camera Raw before you convert a layer to a smart object. If you try to apply it to a non-image layer or if there is no layer selected, you will get a warning. If you have multiple layers selected, they will be merged into one layer before Camera Raw is applied.

Better not crop the image in Adobe Camera Raw, otherwise the resulting smaller image will be centered in the original image and you have to crop it again. So it makes more sense to crop the image after applying Camera Raw.


Camera Raw Smart Object

MetaRaw's Camera Raw Smart Object feature creates a smart object from the selected layer(s), which can be edited with Camera Raw. You can run it in Photoshop from the File > Automate > Camera Raw Smart Object menu item and in Photoshop Elements from the File > Automation Tools > Camera Smart Object menu item. Then the Adobe Camera Raw dialog shows up and you can choose your effect settings. Finally click the OK button (or Open Image button) to turn the selected layers into a smart object.

Please note: If you selected more than one layer before running the Camera Raw Smart Object command, the layers will be merged before they are converted into a smart object. This is necessary because Camera Raw cannot process multiple layers.

To edit the created smart object double click its thumbnail in the Layers panel. As a result the Camera Raw dialog appears and you can change the settings non-destructively. In Photoshop Elements this is only possible if ElementsXXL 3 (or higher) is installed.