Functionality

 

The MetaRaw product includes two plugins. A format plugin, also called MetaRaw, for extending the raw file support and an automation plugin, called Camera Raw Filter, for using Adobe Camera Raw as a filter. The following section refers to the MetaRaw format plugin.

 

General Usage

 

Opening Raw Files with MetaRaw

The MetaRaw format plugin comes into play when you open one or more raw files in Photoshop or Photoshop Elements. You can do that by dragging and dropping the raw files on the Photoshop (Elements) window, by using one of the Open items on the File menu or by opening the files with Bridge or Organizer.

MetaRaw displays a progress window in the top left corner of the Photoshop or Photoshop Elements window. This progress window is semi-transparent and has rounded corners. It tells you what MetaRaw is currently doing.

Firstly the progress windows says "Analyzing ...", which means that it is checking if the raw files are supported by Adobe Camera Raw. Usually this happens so fast (unless the Adobe Camera Raw plugin still needs to be loaded) that you do not see it.

Next, the main dialog of MetaRaw shows up (if it was not suppressed with the Do not display option) and lets you adjust the MetaRaw settings. If the dialog does not show up, MetaRaw reacts according to the previously adjusted settings.

If the progress window displays "Converting ...", the Adobe DNG Converter or MetaRaw Converter is currently converting a file. You will see a blue progress bar that indicates how long it will still take. If Camera Raw is used for conversion, you will not see this message.

Then the Adobe Camera Raw dialog shows up (unless you deactivated the Display Camera Raw Dialog check box on the main dialog). Here you can make various image adjustments. Click the Open Image(s) button to continue.

In the final step the progress window shows "Opening ...", which occurs right before the images appear as documents in Photoshop or Photoshop Elements.

If there was a problem and the Metaraw progress window does not vanish, you can click the x icon in the top right corner to close it.

 

Using MetaRaw from the Open As file dialog

The Open As command in Photoshop lets you open a file as a certain file format. This is useful if Photoshop does not recognize a certain file extension or if you want a non-raw file to be opened with Camera Raw. With MetaRaw installed you will see two Camera Raw items on the Open As combo box of the Open As file dialog. The item with more file extension is MetaRaw. If you want to temporarily bypass MetaRaw, you can choose the Camera Raw item with the fewer file extensions.

Please note: Photoshop would normally run Adobe Camera Raw instead of MetaRaw, so MetaRaw internally uses the name "Camera Raw" to avoid this. That is why you do not see a MetaRaw item but two Camera Raw items on the Open As file dialog and the Help > About Plugins sub menu. In Photoshop CS3 and higher this could be avoided by deactivating the Prefer Adobe Camera Raw for Supported Raw Files check box under Edit > Preferences > File Handling. It would probably also be possible for MetaRaw to deactivate a similar hidden setting in Photoshop Elements 6 and higher. But MetaRaw also supports Photoshop CS1/CS2 and Photoshop Elements 3-5, which do not have such a setting, which is why this strategy was chosen.

 

Batch Processing with MetaRaw

Batch processing raw files with MetaRaw installed does not differ from your normal workflow with Adobe Camera Raw. In Photoshop you have to record an action that opens a raw file, applies some effects, saves the raw file and closes it. On the File > Automate > Batch dialog you have to choose this action and activate the two Override check boxes. In Photoshop Elements you choose File > Process Multiple File from the menu and activate the Convert File to check box. After adjusting the other batch settings, you can click OK.

During batch processing the MetaRaw dialog will show up for each file unless you previously activated the Do not display check box. So if the MetaRaw dialog shows up, choose your settings, activate the Do not display check box and click OK. Now it will not show up again for the remaining files.

If you want MetaRaw to show its dialog again by default, go to Help > About Plug-Ins > Camera Raw (under Windows) or Adobe Photoshop (Elements) > About Plug-Ins > Camera Raw (under MacOS), deactivate the Do not display check box and click OK.

If there was a problem and the Metaraw progress window does not vanish, you can click the x icon in the top right corner to close it.