Cloak Mode


Cloak Mode only works with the Plugin version of B/W Styler. In Cloak Mode B/W Styler doesn't display its dialog and immediately starts rendering a predefined setting to the image. Cloak mode is useful if you want to quickly apply the same settings to a series of photos.



Activating Cloak Mode

To activate Cloak Mode hold down the CTRL key when you click on the Cancel button. The information box pictured above will appear. After pressing YES, the current settings will be saved and B/W Styler will be exited without rendering any effects to the image.

When you run B/W Styler again by choosing it from the Filter menu of your image application, the dialog of B/W Styler won't show up and the previous settings will be rendered immediately to the image. So if you have the On Start Up combo box on the Prefs tab sheet set to "Default Settings", this setting is ignored in Cloak Mode and the previous settings are applied. However, if you have On Start Up set to "Logged Settings", B/W Styler will search for automatically logged settings for each image and apply them if they are available.

Leaving Cloak Mode

After you have processed your series of photos in Cloak Mode you can uncloak B/W Styler again. To do that, hold down the Shift key when selecting B/W Styler from the menu in your image application. This exits Cloak Mode and displays the B/W Styler dialog again.

Alternatively you can also delete the file BWCloak.ini in the B/W Styler folder. But this is just an emergency strategy.

 

 

Batch Processing using Cloak Mode in Photoshop

Photoshop offers a Batch feature on its File > Automate menu. This feature lets you batch process a series of images with the help of a Photoshop Action. So if you want to batch process images in Photoshop you only need to record an action that contains B/W Styler.

 




To record an action with B/W Styler do the following:

1. Open an image in Photoshop.

2. Switch to the Actions palette on the right and create a new action by using the New Action button or the pop-up palette menu.

3. Choose B/W Styler from the Filter menu and press OK. You don't need to adjust any setting or enter Cloak mode yet.

4. Press the Stop button on the Action palette. Now you have your B/W Styler action that you can use with File > Automate > Batch.

 


To batch process a series of images with B/W Styler please do the following:

1. Open one of the images from the image series.

2. Run B/W Styler and adjust its settings.

3. Enter Cloak Mode by holding the CTRL key and clicking on the Cancel button.

4. Select File > Automate > Batch.

5. In the Batch dialog make sure that your B/W Styler action is selected.

6. Set the other batch options and click on OK to run it.


If you want to batch process another series of images with other B/W Styler settings, please uncloak B/W Styler as mentioned above, adjust the settings and return to Cloak Mode again. You don't need to create another action for that purpose as you would need to do for other plugins.

If you want to apply individual B/W Styler settings to each image during batch processing, run the action without activating Cloak mode. In this case the B/W Styler dialog will pop up for adjusting the settings for each image. To apply them just click on OK.

 

 

Batch Processing in Cloak Mode in Paint Shop Pro 8 and higher

Paint Shop Pro 8 (and higher) offers a Process feature on the File >Batch menu for batch processing a series of images with the help of a PSP script. Recording such a script is quite easy.


To record a PSP script with B/W Styler, please do the following:

1. Open an image in PSP.

2. Select File > Script > Start Recording.

3. Choose B/W Styler from the Filter menu and press OK. You don't need to adjust any setting or enter Cloak mode yet.

4. Select File > Script > Stop Recording and save the script. Now you have a B/W Styler action that you can use with File > Batch > Process.


To batch process a series of images with B/W Styler please do the following:

1. Open one of the images from the image series.

2. Run B/W Styler and adjust its settings.

3. Enter Cloak Mode by holding the CTRL key and clicking on the Cancel button.

4. Select File > Batch > Process.

5. In the Batch Process dialog choose your B/W Styler script with the Browse button from the Script frame.

6. Set the other batch options and click on the Start button to run it.


If you want to batch process another series of images with other B/W Styler settings, please uncloak B/W Styler as mentioned above, adjust the settings and return to Cloak Mode again. You don't need to create another script for that purpose as you would need to do for other plugins.
If you want to apply individual B/W Styler settings to each image during batch processing, don't activate Cloak mode and run the script nevertheless. Then for each image the B/W Styler dialog will pop up for adjusting the settings. To apply them just click on OK.

 

Batch Processing using Cloak Mode in other image editors

There are some other applications that support batch processing with the help of plugins. For example, Equilibrium DeBabilizer supports it and some other applications may support it in future. Basically batch processing in other applications works the same as in Photoshop. You have to activate Cloak Mode in B/W Styler and select the B/W Styler plugin for batch processing in the batch feature of these applications.