General Usage

 

Running the Plugin

Run your image processing application of choice, e.g. Photoshop, and open an image file. To launch LightMachine please open the menu that leads to the plugin filters (e.g. the Filter menu in Photoshop and Elements, the Image -> Plug-ins in Paint Shop Pro or the Effects menu in Photo-Paint) and choose "LightMachine" from the PhotoWiz sub menu.

If LightMachine appears grayed out on the menu, then the mode of the opened image is not supported by it. That is the case if your image has e.g. only 256 colors, 32-bit per channel or is a CMYK image. Then you have to convert it in your image application to RGB before you can start working on it with LightMachine. In Photoshop that is done on the Image > Image Mode menu.

 

Running the Standalone

To run the standalone of LightMachine, double click the LightMachine icon on the desktop or choose it from the Start > All Programs > The Plugin Site > LightMachine Standalone menu. After LightMachine shows up click the Open button in the bottom right corner to open one or more image files. You can also click arrow-down button in the top left corner to display a menu with file options.

 

Running the Lightroom Version

To run LightMachine in Lightroom, select one or more images and choose the LightMachine menu item on the Photo > Edit In menu. Alternatively you can also right click on an image and choose Edit In > LightMachine from the context menu. The following dialog will appear:

If you selected RAW files, you will only be able to select the option "Edit a Copy with Lightroom Adjustments". If you edit a JPEG or TIFF file, you will also see the other two radio buttons. We recommend that you use the first or second option in this case. Never use "Edit Original" unless you have a backup copy of the file(s).

We suggest that you keep the Copy File Options settings as they are to avoid reduced image quality or a slower startup of LightMachine. By using "ProPhoto RGB" for the Color Space option you preserve the as much image colors as possible. If you use other external editors in Lightroom that do not support color management, changing the option to "sRGB" may be a viable compromise. If you do not use the "16 bits/component" setting, you may get reduced image quality. If you do not use the "None" compression settings, LightMachine will need longer to start up. On the other hand the "Stack with original" keeps the original and LightMachine-processed copy of the image side by side in Lightroom, so it is rather a question of your workflow if you want that or not.

Finally press the Edit button to run LightMachine. If you if you selected RAW image files, Lightroom now creates TIFF copies of them, which may take some time. For JPEG and TIFF files LightMachine appears much faster.

 

Running the Lightroom Version in ACDSee (Pro / Ultimate)

To run LightMachine in ACDSee switch to Manage or View mode, select the image you want to edit and choose Tools > External Editors > LightMachine from the menu.

 

Running the Lightroom Version in AfterShot Pro

To run LightMachine in AfterShot Pro, right click on one of the thumbnails in the thumnbail panels and choose the Edit with > LightMachine from the context menu. Alternatively you can use the Edit > Edit with > LightMachine menu item from the top.

 

Running the Lightroom Version in CaptureOne

To run LightMachine in CaptureOne, select an image from the browser, choose File > Edit with… from the main menu (or right click from the browser and select Edit With…). Select TIFF or PSD as the image format from the appearing dialog, choose 16-bit as the bit depth and no compression. Choose Other from the Open With…drop down menu and navigate to the LightMachine installation folder. Finally click on the Edit button to run LightMachine. Alternatively the File > Open with… menu item lets you edit the original image file, which is usually not recommended.

 

Running the Lightroom Version in DxO Optics

To run LightMachine in DxO Optics, open an image and go to "File > Export to application" from the main menu or right click on a thumbnail and select "Export to application". In the appearing dialog click the Browse button, choose the LightMachine installation folder from the file dialog, e.g. at C:\Program Files\The Plugin Site\, and double click on the LightMachineLR.exe file. From the Action combo box select the item "Process as TIFF and export" and under Quality choose "16-bit". Finally click the Export button. Click OK on the LightMachine dialog when you are finished and back in DxO Optics click on the newly created thumbnail to see the result. The next time that you go to File > Export to application you can choose LightMachine from the Export to combo box and do not need to locate it first.

 

Running the Lightroom Version in Exposure

To run LightMachine in Exposure X2 or higher, select an images at the bottom, right click on the thumbnails or the displayed image and choose the Edit Copy In > LightMachine from the context menu. Please note if you use the Edit In > LightMachine menu item, the original file will be overwritten when clicking OK in LightMachine.

 

Running the Lightroom Version in ON1 Photo Raw

To run LightMachine in ON1 Photo Raw, open an images file and choose File > Send to Other Application... from the menu. Now choose the LightMachine installation folder from the appearing file dialog, e.g. at C:\Program Files\The Plugin Site\, and double click on the LightMachineLR.exe file. On the appearing Edit In dialog choose "Edit a Copy ...", from the File Format combo box select "Photoshop" and from the Bit Depth combo box select "16-bit". Choose a color space as you see fit. Finally click the Edit button. ON1 Photo Raw now creates a new image and runs LightMachine. In LightMachine click OK to save the effect.

The next time you do not need to use the File > Send to Other Application menu item, because there will be a dedicated File > Send to LightMachine menu item available, which you can use.

 

Running the Lightroom Version in Raw Therapee

At first you have to enter the path of LightMachine under Preferences > General > External Editor > Other command line. The path should usually be e.g. "C:\Program Files\The Plugin Site\LightMachine\LightMachineLR.exe" or "C:\Program Files\The Plugin Site\PhotoWiz\LightMachineLR.exe", but please check yourself in Explorer to be sure.

To run LightMachine in Raw Therapee click the "Edit Current Image in External Editor" button on the Editor tab or at the bottom-left of the Preview panel.