[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 113: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 113: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5277: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3903)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5277: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3903)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5277: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3903)
The Plugin Site • Plugins Making Me Crazy!
Page 1 of 1

Plugins Making Me Crazy!

Posted: Wed Mar 19, 2014 5:58 am
by Muriel
Good Evening..

I am using PSP X14, running Windows 8.1 64bit, with i7 processor. Half the plugins that worked in Vista no longer work for me. In some cases they simply crash the program. Otherwise they freeze the program with this display or some variation thereof.


I have turned on DEP for all programs except PSP X4. The two dll files are installed in the SysWOW64 file.

Some of these filters are ones I use frequently, so I would dearly love to have them functioning again.

What are my options? Any help or suggestions are appreciated!

Many thanks..

Muriel!

Re: Plugins Making Me Crazy!

Posted: Thu Mar 20, 2014 1:56 am
by Muriel
G;Day!

Muriel Again, this time with Chapter 2!

I bought and installed Version X6 today and would you believe even though the folders are rightly and properly linked, not one lonely plugin appears in the program!! And it comes as no surprise that when I tried to add it to the list of programs for which the DEP should be turned off, I was informed that I am 'NOT ALLOWED' to change this setting in 64-bit programs! NO kidding, I mean, I couldn't make this stuff up!

Bottom line is that the situation is far worse with this program than it was with Version X4, and I despair of fixing it! If there is anything I can do, someone to whom I can speak, I would be eternally gratefully.

Muriel!

Re: Plugins Making Me Crazy!

Posted: Thu Mar 20, 2014 6:05 am
by Muriel
And you thought you had heard the last from me!

I think I am beginning to figure this out, even though I doubt there will ever be a solution. I installed Version X6 in 64-bit mode, and it didn't recognize any of plugins. Uninstalled and reinstalled it in 32-bit mode and it saw them, same as Verson X4 did earlier, and with exactly the same issues. The conclusion is that the issue is with the plugins, so I am wondering: Is there is a way to convert these rogue plugins so they work in this 64-bit machine?

Muriel!

Re: Plugins Making Me Crazy!

Posted: Thu Mar 20, 2014 7:48 pm
by Muriel
Good Afternoon!

Hi!

I installed the 32-bit version of PSP X6, and even though it sees the plug-ins, they still do not work. It is exactly the same issue I had with Version X4, which of course is in the 32-bit format by default, when I began this thread.

I sent an e-mail off to Corel Support and Nelson replied overnight. His advice was to uninstall and then reinstall the program in the 32-bit format, but that has been done at least three times. The little '32 box' in the lower right corner of the camera logo in my start menu confirms that it is indeed installed in that format. Having said that, when I tried to turn off the DEP for that program, I was informed that I am 'not allowed' to change the settings on a 64-bit program! Seems Windows sees it in the 64-bit format no matter what I do! :evil:

So, I still have to wonder Is there is a way to convert these rogue plugins so they work in this 64-bit machine?

I think I have hit a brick wall!

Muriel!

Re: Plugins Making Me Crazy!

Posted: Thu Mar 20, 2014 8:35 pm
by Muriel
Well, Hello Again!

She's DOING A HAPPY DANCE! : :P

I found the solution! Seems the 32-bit program lives in c/program files(x86). There is another version in c/program files which is the one I was trying to modify by turning off DEP, but Windows views that one as the 64-bit version! Once I turned off the DEP in the 32-bit version and after living and breathing this for three days, I was flabbergasted to find the plugins WORK! (They still don't work in Version X4, which should come as no surprise, given it is not on Windows List of Supported Corel Programs.)

Just in case there is someone else out there tearing their hair out over this annoying frustration, this is how to turn off the DEP in Windows 8.. exactly the same as in all the other versions, actually.

Settings
Control Panel
System
Advanced System Settings
Performance Settings
Data Execution Prevention
Turn off DEP for all programs except the ones I choose
Click on ADD. Find the program you need to add.
Apply, okay

Re: Plugins Making Me Crazy!

Posted: Fri Mar 21, 2014 1:05 am
by HaraldHeim
If you turn off DEP for PSP X4, the plugins should also work there.

Re: Plugins Making Me Crazy!

Posted: Fri Mar 21, 2014 5:21 pm
by Muriel
Good Morning, Harold Heim!

Oh my goodness, I tried that one more time and BINGO! The plugins in X4 now work!

I had tried turning off the DEP in X4 perhaps ten times in the past few days, with no effect whatsoever. When I checked back, I found it was no longer there - only Version X6! Today it stuck! :roll: Mine is not to reason why..

You put me onto that 'turn off the DEP' trick years ago.. and I thank you.

This has been an amazing learning experience for me and thank-you to everyone who replied to this thread.

Muriel!

Re: Plugins Making Me Crazy!

Posted: Sun May 04, 2014 4:11 am
by patara
I never turn off DEP for PSP and there are only 1 or 2 old filters I cannot get to work in X6 or the later versions of PSP but they are not related to DEP. From what I've seen, usually the ones causing the DEP issue are those that can be patched with the FMPatcher. Once they are patched they work fine. Some other filters need to be updated via the developer's website.

Re: Plugins Making Me Crazy!

Posted: Sun May 04, 2014 12:22 pm
by HaraldHeim
With an older CPU or older version of Windows DEP is not an issue, which may explain your case. But with newer CPUs and Windows Vista, 7 and 8, you have to turn off DEP for FilterFactory plugins and as well as older FilterMeister plugins.

Re: Plugins Making Me Crazy!

Posted: Fri Oct 17, 2014 2:18 am
by patara
Harald, I have Win 8.1 with all Updates and my system is only 18 months old and as mentioned I have never had to turn DEP off for PSP, with any version up to version X6. I don't have X7 installed. I have 1,000's of FF and FM filters and they work fine for me. I added the 1 required dll file for FF filters and I patch any FM filter that requires it, plus I always look for the latest versions.

Re: Plugins Making Me Crazy!

Posted: Fri Oct 17, 2014 3:38 am
by HaraldHeim
DEP is not supported by some older CPUs. So it could be that you are still using an old computer and do not need to switch off DEP.

Re: Plugins Making Me Crazy!

Posted: Fri Oct 17, 2014 4:10 am
by patara

Re: Plugins Making Me Crazy!

Posted: Fri Oct 17, 2014 12:24 pm
by HaraldHeim
Then your DEP setting was probably already set to system programs only.

Re: Plugins Making Me Crazy!

Posted: Fri Oct 17, 2014 1:22 pm
by patara