Page 1 of 1

Lightmachine Auto Mask Displays in 16bit

Posted: Sat Nov 17, 2007 11:30 am
by archipel
I am running LM 1.0b in Photoshop CS3 for 16bit images on a layer. When activating the Shadows or Highlight previews, the respective areas are not made transparent -- switching to 8bit does the trick. Is this a bug or I am doing something fundamentally wrong?

I am also looking at similar issue for the spots under Virtual Studio Pro, but I will have to get back to you on that.



Posted: Sun Nov 18, 2007 1:20 am
by HaraldHeim
You mean the S and H buttons, right? Are you refering to the Win or Mac version of LightMachine. I just checked the Win version and it works there.

Posted: Sun Nov 18, 2007 9:08 am
by archipel
Yes, S and H buttons on Win XP platform. For some reason they do not work for me.

Posted: Sun Nov 18, 2007 12:57 pm
by HaraldHeim
Strange. Maybe the problem only occurs with a certain setting. Please click Reset and then try again. Does it work now?

Posted: Sun Nov 18, 2007 1:58 pm
by archipel
Thanks, Harald. Reset does not help. The strange thing is that the N and P buttons work...

Posted: Sun Nov 18, 2007 9:40 pm
by HaraldHeim
Do you have the Lock Transparency icon activated in Photoshop's Layers palette? That would explain your problem.

Posted: Mon Nov 19, 2007 6:46 am
by archipel
The transparency icon has been always unlocked. If I switch from 16bit to 8bit the behavior is as expected. Beats me.

Posted: Tue Nov 20, 2007 7:44 pm
by archipel
I did flatten the 16bit image, then had a side by side comparison with the same flattened image converted to 8bit. Then, did apply LM to both but to the respective background layer and it works identically for both H and S buttons... So the issue must be related to a layer setting/quirk in 16bit. I am running CS3 10.0.1.

Posted: Thu Nov 22, 2007 12:45 pm
by HaraldHeim
Another possibility is that you changed/deactivated the transparency display in the Photoshop preferences. But then you would not see a chessboard pattern for any transparent image area in Photoshop.