The Button Bar


Right below the two main panes, Plugin Commander has a button bar for selecting the most commonly used commands.

The Preview Icon: You can enter the preview mode by choosing 'Preview' from the View menu or by pressing this icon. If a plugin, PSP add-on or image is selected in preview mode, the Preview window will pop up and show you a preview of the selected file. The preview is calculated in real-time for Photoshop-compatible 8bf plugins and rendered by PSP for PSP add-ons. For other files Plugin Commander searches for a preview image in the Preview sub folder. If one is found, it is displayed. Please read the text file in the Preview sub folder for information on creating your own preview pictures for certain files.

In the title bar of the Preview window behind the word 'Preview' there are some words in brackets that explain how the displayed image was created. (from cache) means that Plugin Commander already calculated an effect preview for the selected plugin and loaded the cached image. (calculated) means that the effect of the image was just calculated with the help of the current preview image and the plugin. (preview folder) means that an image that has the same name as the plugin was loaded from the preview sub folder. (rendered by PSP) means that Paint Shop Pro was executed invisible in the background to render the preview. If Plugin Commander was problems displaying an image in the Preview image, it will be left blank or 'Plugin Problem' will be displayed.

The Preview window can be placed anywhere you like by dragging the title bar. You can resize it by dragging its borders. However with a larger Preview window it may take longer to calculate a plugin preview, but it will have no influence on the rendering speed of images and PSP add-ons. The size and position of this window will be saved and restored the next time you start Plugin Commander.

If a Filter Factory plugin is selected, double clicking the image in the Preview window will calculate a random effect. Right clicking on it will display a part of the File menu. You can leave the Preview mode by clicking on the Preview icon again or by choosing 'Preview' from the View menu a second time.

The Overlay Icon: This feature will only be available if the Preview icon is active. It only works in conjunction with Photoshop-compatible plugins including Filter Factory plugins. If the Overlay icon is activated, the plugin effect applied to the preview image will remain and won't be removed when selecting a new plugin. That way you can preview the effect of consecutive applied plugins.

The Alpha Icon: Like the Overlay icon it will only work if the Preview icon is activated. It only works for Filter Factory plugins. If the currently selected Filter Factory plugin contains code for manipulating the alpha channel, this feature will make it visible as a greyscaled or blue/yellow effect.


For the other buttons see

The Convert Command
The Browser
The En/Disable Command
The Change Cat(egory) Command
The Create FFL Command



Back to Main